Chnoili
Enthusiast
Enthusiast

vSphere 6 - You do not have permissions to view this object or this object does not exist

I installed a new vCenter Server, when i log in, on some pages i have the message:" You do not have permissions to view this object or this object does not exist".

Im Administrator on the vCenter (administrator@vsphere.local) and i put another user in the admin group - same message

When i login with the same user on the vsphere desktop client, i can do all the operations.

Can anybody help?

Thanks

access.JPG

17 Replies
usernameAZaz09
Contributor
Contributor

I have exactly this same issue. Installed vCenter twice from scratch.

Can anybody help? Thanks Smiley Happy

0 Kudos
ThomasDeLaire
Contributor
Contributor

I had the same issue, what my issue was is that I logged in just using administrator and what I thought was the password I setup, which got me in, but displayed the information you guys both saw.

When you login, you have to use administrator@vsphere.local and the password you setup. At least that is what worked for me.

snekkalapudi
VMware Employee
VMware Employee

I exactly ended up in the same situation like yours when I deployed. All I did is logged in as administrator@vsphere.local (The SSO administrator user) and provided my other user(say 'vcadmin') an administrator role (Administration->Global Permissions->Manage) Now I re-logged in with vcadmin and I could access the tab.

-Suresh
Chnoili
Enthusiast
Enthusiast

I have still the same problem - it doesn't matter if i'm logged in as administrator@vsphere.local or with my active directory account - which is in the administrator group

I made a installation with vsphere 5.5 and everything worked fine - with my AD account - then i made a upgrade to vsphere 6 - same problem again

0 Kudos
ThomasDeLaire
Contributor
Contributor

What OS are you using? I chose 2008 R2 myself, I still don't fully trust 2012 R2 with 3rd party software.

0 Kudos
Chnoili
Enthusiast
Enthusiast

I use Windows 2012 R2 - with Vsphere 5.5 there is no issue, The Database is a SQL 2012 installation on a other server. i try now to install a plain windows 2012 server (without any additional software) and a local DB, perhaps there is a problem with a other software.

0 Kudos
ThomasDeLaire
Contributor
Contributor

I'd recommend 2008 R2 myself if 2012 or 2012 R2 doesn't work.

A lot of 3rd party software is still buggy post-2008 R2. Take Spiceworks for instance, I installed it to 2012 R2 and ran discovery, it picked up about 1/3 of the environment. I installed to 2008 R2, same machine, same network, it discovered 100% of the environment.

Few other things I have seen that has had similar issues too. Hence, don't trust 2012 and 2012 R2 with 3rd party software... yet.

0 Kudos
Chnoili
Enthusiast
Enthusiast

OK, i installed vcenter 6 on a plain Windows 2012 R2 with a local database - everything works fine. i think there is a problem with a 3rd party software on my real vcenter server - i try to deinstall all other software on the server before i install vcenter 6

0 Kudos
bfarahi
Contributor
Contributor

I'm having the exact same issue.   I'm using vSphere 6.0 Build 26567760 which I believe is the latest.   My VC is 2008 R2 Enterprise.   Anyone have a workaround?   Thanks.

0 Kudos
jkoebrunner
Enthusiast
Enthusiast

Same issue here - any solution yet?

Johannes Köbrunner IT Solutions Architect Virtualization, Network and Storage Systems Frequentis AG VTSP, VCP, VCAP-DCD
0 Kudos
jholeci
Contributor
Contributor

Hi

Finally got workaround from Vmware, in my case adding all vsphere and Kerberos paths for Local system account solved web client permission issue see detailed instructions below.

Hope it helps

Jan

 

Please try the following. (before that please create a backup from the vCenter server)

 

In regedit system wide path is defined here:

 

Computer\HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Session Manager\Environment->Path

 

 

Local system account overridden Path is defined under:

 

Computer->HKEY_USERS->S-1-5-18\Environment->Path

 

 

(first step, second location can be verified if exists; and if exists values can be compared to see differences)

 

 

You can either remove(rename) the existing override

 

(Computer->HKEY_USERS->S-1-5-18\Environment->Path) completely. This will make the system wide Path to take effect.

 

Or if this override was specified on purpose (for some reason), then modify

 

Computer->HKEY_USERS->S-1-5-18\Environment->Path to make sure to include MIT Kerberos installation (such as c:\Program Files\MIT\Kerberos\bin), and possibly other vSphere paths (like OpenSSL) for completeness.

0 Kudos
usernameAZaz09
Contributor
Contributor

Thanks a lot! I can confirm it works

0 Kudos
naymar27
Enthusiast
Enthusiast

Hey guys, i have the same message when i log in with my account or administrators account. I don't know what to do?

Can somebody help me please.

0 Kudos
likeahoss
Enthusiast
Enthusiast

Hopefully you've fixed your issue by now, but for everyone else that came here through Google, see the following KB:

VMware KB: After Installing or Upgrading to vCenter Server 6.0, logging in to the vSphere Web Client...

0 Kudos
tramco
Contributor
Contributor

Thanks pikasuoh,

The link provided solved my issue.

No need to edit registry.

0 Kudos
ITSavant
Contributor
Contributor

SOLUTION

I have Multiple vCenters using a separate Platform Services Controller, authenticating an AD Forrest with Multiple domains.

Only Users in the same domain as the PSC and vCenters could See the VSC icon, other Admins using AD accounts in the other domains could not see VSC.

To Fix Problem

Log in to vCenter as administrator@vsphere.local

Administration -> Access Control -> Global Permissions -> Manage Tab

Add New Group

  User/Group: your.ad.domain/AD.User.Group

  Permission: VSC Administrator  (as Created by VSC Installation)

0 Kudos