Highlighted
Hot Shot
Hot Shot

vCenter Server Appliance 5.5 won't join AD domain

Jump to solution

I am trying to join vCenter Server Appliance 5.5 to Windows Server 2012 AD domain authentication but I am getting following error message


AD Authentication settings

Error: Invalid hostname. FQDN is required for joining a domain.

vCSA_AD_error.png

DNS is OK, vCSA can resolve both domain and domain controller host name.

Same DC, and parameters work just fine with 5.1.

Anyone else sees this?

Tomi http://v-reality.info
1 Solution

Accepted Solutions
Highlighted
VMware Employee
VMware Employee

After logging in to the VCSA management interface ‘https://vcenterserverip:5480’ and navigating to ‘Network->Address’, if the hostname is present without the domain.

If your Hostname is entered with just vCenter hostname then change it into FQDN as <vCenter-hostname>.vclass.fi in your case.

------------------------------------------------------------------------------------------------------------------------------------ If you find this or any other answer useful please mark the answer as correct or helpful. Abhilash B | Blog : http://vpirate.in | Twitter : @abhilashhb | LinkedIn : https://www.linkedin.com/in/abhilashhb/ |

View solution in original post

13 Replies
Highlighted
VMware Employee
VMware Employee

It happens if you have. .local in the domain name

------------------------------------------------------------------------------------------------------------------------------------ If you find this or any other answer useful please mark the answer as correct or helpful. Abhilash B | Blog : http://vpirate.in | Twitter : @abhilashhb | LinkedIn : https://www.linkedin.com/in/abhilashhb/ |
Highlighted
Hot Shot
Hot Shot

No, that is not the cause. I built new domain with another name and I still get same error message.

vCSA_AD_error2.png

Tomi http://v-reality.info
0 Kudos
Highlighted
VMware Employee
VMware Employee

Have you added the DNS Entry for the vCenter Server? Are you able to ping the vCenter with the hostname?

------------------------------------------------------------------------------------------------------------------------------------ If you find this or any other answer useful please mark the answer as correct or helpful. Abhilash B | Blog : http://vpirate.in | Twitter : @abhilashhb | LinkedIn : https://www.linkedin.com/in/abhilashhb/ |
0 Kudos
Highlighted
Hot Shot
Hot Shot

Yes, like I said on initial post DNS settings are in place. Network connectivity between vCSA and DC is OK.

Tomi http://v-reality.info
0 Kudos
Highlighted
VMware Employee
VMware Employee

After logging in to the VCSA management interface ‘https://vcenterserverip:5480’ and navigating to ‘Network->Address’, if the hostname is present without the domain.

If your Hostname is entered with just vCenter hostname then change it into FQDN as <vCenter-hostname>.vclass.fi in your case.

------------------------------------------------------------------------------------------------------------------------------------ If you find this or any other answer useful please mark the answer as correct or helpful. Abhilash B | Blog : http://vpirate.in | Twitter : @abhilashhb | LinkedIn : https://www.linkedin.com/in/abhilashhb/ |

View solution in original post

Highlighted
User Moderator
User Moderator
Highlighted
Hot Shot
Hot Shot

Aha, that's it!

I only had vcapp in hostname field, but vCSA is expecting FQDN. Error message even makes perfect sense now, I just didn't thought of checking vCSA end..

Btw,  vCenter Server Appliance hostname is set by vApp properties in VM settings, not by https://vcapp:5480 web GUI.

Tomi http://v-reality.info
0 Kudos
Highlighted
Contributor
Contributor

Smiley Happy thanks for reporting this. I just import the Vmware vCenter Server 5.5 appliance and integration with AD was not working..

After adding the correct hostname, integration was successfully.

0 Kudos
Highlighted
Contributor
Contributor

This helped me also. I had entered the hostname without the FQDN and it was gone when I checked.  I added the Hostname again as a FQDN, but also noticied that the IPv4 Default Gateway was gone.  Put the IP address back in and it accepted the Hostname.  Went back to the AD Authentication settings and it allowed me to put in the domain name, Admin user, and Password successfully.  Thanks for your help.

0 Kudos
Highlighted
Contributor
Contributor

Thank you! This was exactly what I needed to fix my issue....

For the record, don't ever delete your vcenter computer from active directory thinking it was your old windows based vcenter 0o :smileyblush:

0 Kudos
Highlighted
Enthusiast
Enthusiast

Thanks for the tip. This helped me to fix the issue in my home lab.Smiley Happy

0 Kudos
Highlighted
VMware Employee
VMware Employee

Glad it helped you Smiley Happy

------------------------------------------------------------------------------------------------------------------------------------ If you find this or any other answer useful please mark the answer as correct or helpful. Abhilash B | Blog : http://vpirate.in | Twitter : @abhilashhb | LinkedIn : https://www.linkedin.com/in/abhilashhb/ |
0 Kudos
Highlighted
Contributor
Contributor

Just a note to add to this for others.  I had a similar issue, looking at the log file gave me the immediate answer for my case.

vpxd_cfg.log said it failed to ping domain blah.local

I did a PING blah.local and got back a strange IP that didn't exist.

Examining DNS I somehow had a A record for blah.local pointing to the bad IP.

Removing the bad A record fixed it and the vCenter Appliance joined the domain OK.

In short, ensure that DNS has an A record for the FQDN that points to the correct IP for your AD DNS servers.