coopscivic
Contributor
Contributor

vCenter Server 6.7 + issue applying patches

Hello,

I have a vCenter Server 6.7 Virtual Appliance running within my environment. It is currently on build 6.7.0.10000. I am trying to install the vCenter Server 6.7.0d patch (Build 9451876). It looked like it was going fine. I checked back a few hours later as the system indicated vCenter will be unavailable for 91 minutes while it performed the upgrade. When I got back, it appeared as if it did not patch based on checking the CPU performance. I tried to manually install the patch by mounting the patch as an ISO to the appliance and executing the "software-packages --stage iso" and "software-packages install --stage" commands. When it runs the install, it says:

Command> software-packages install --staged

[2018-09-05T02:11:10.248] : Validating software update payload

[2018-09-05T02:11:10.248] : Validation successful

[2018-09-05 02:11:10,062] : Copying software packages  [2018-09-05T02:11:10.248] : ISO mounted successfully

2/2

[2018-09-05T02:11:10.248] : ISO unmounted successfully

[2018-09-05 02:11:10,546] : Running test transaction ....

[2018-09-05 02:11:11,595] : Running pre-install script.....

[2018-09-05 02:12:07,729] : Upgrading software packages ....

[2018-09-05T02:12:08.248] : Package update failed

[2018-09-05 02:12:08,738] : Starting all services ....

[2018-09-05T02:17:45.248] : Services started.

[2018-09-05T02:17:45.248] : Installation process failed at upgrade stage

Command>

If I try to rerun the iso directly from the appliance web url, It shows the error "Update installation failed, vCenter is non-operational" at the backup vCenter Server Stage.

I tried using any of the previous builds of vCenter Server appliance 6.7 with the same result.

I also tried rebooting the appliance.

Note: I am able to login to vCenter Server and manage the environment with no issues. The only thing that appears to be having some issues is applying updates to the appliance.

I downloaded the support bundle but do not know where in the bundle the logs are located. Any help would greatly be appreciated.

9 Replies
EricChigoz
Enthusiast
Enthusiast

Hello coopscivic,

Please be sure of your VCSA version and see if this can help.

pastedImage_0.png

Find this helpful? Please award points. Thank you !
0 Kudos
coopscivic
Contributor
Contributor

Hi EricChigoz,

The VCSA version I posted is from the DCUI. It is VCSA 6.7 without any patches since the initial release of VCSA 6.7.

0 Kudos
Vijay2027
Expert
Expert

Please attach messages log (Location: /var/log/vmware) and software-packages.log (Location: /var/log/vmware/applmgmt)

What is the output of the command:

# chage --list root

0 Kudos
Vijay2027
Expert
Expert

Copy files using winscp:

VMware Knowledge Base

0 Kudos
ivyinfosec
Contributor
Contributor

dsdavis08
Enthusiast
Enthusiast

This solved the issue for me. Thank you!

0 Kudos
bascheew
Enthusiast
Enthusiast

This got me on the right track.  When I ran

software-packages install --url

I got an error about no updates available.  So I downloaded the patch from https://my.vmware.com/group/vmware/patch#search​, mounted the ISO to the vCenter appliance and then instead ran

software-packages install --iso

and it worked.  Thanks!

HamR
Enthusiast
Enthusiast

software-packages install --iso

^ this worked for me. Thanks.

AktionJThomas
Contributor
Contributor

the command

update.set --currentURL default

should allow you to use

software-packages install --url
0 Kudos