Raudi
Expert
Expert

vCenter HA deployment

I'm a little bit confused, i'm trying to deploy vCenter HA in "basic mode" because i'm totally bugged from the advanced deploment. (Every time something fails we must redeploy the complete installation) In the past we must deploy in advanced mode, because our witness was in a different routed subnet.

We have a big HA cluster with several hosts in 2 separate datacenters. Now we have deployed a single ESXi Host (managed by the same vCenter) in a third local datacenter with a connection to the vCenter HA network.

Can someone tell me why the witness must be in the same cluster with the active and passive node?

Has someone deployed the vCenter HA in basic mode and moved the witness to a different host out of the cluster after deployment via storage vMotion? (Network will be the same.)

Tags (1)
0 Kudos
7 Replies
daphnissov
Immortal
Immortal

because i'm totally bugged from the advanced deploment.

What does this mean?

Can someone tell me why the witness must be in the same cluster with the active and passive node?

Because when you use the "simple" deployment, having all the nodes in the same cluster is simple. If you have more complex needs (like you just demonstrated), you can't use the "simple" deployment mode.

0 Kudos
Raudi
Expert
Expert

I have still a support ticket open regarding the statsmonitor service startup, a few weeks ago the support requested additional debug logs, i got a list with commands what to do, but one command was wrong after this the vcenter services don't came up after reboot. I tryed to rech the support, but the customer has only support on normal working days/hours. One day later i searched and figured out that a copy of a config file is resulting in this error. After deleting the backup copy the vcenter was able to startup. But it don't recognizes the witness after that.

(The command was: cp /etc/vmware/vmware-vmon/svcCfgfiles/statsmonitor.json /etc/vmware/vmware-vmon/svcCfgfiles/statsmonitor.json.bak

there is a service that parses all files in the directory, and when there is a duplicate file, the service fails, the backup copy must be in a different directory, was a mistake of the supporter.)

This is only one example where the vCenter HA installation fails. This advanced installation makes too much work.

When in advanced deployment something fails it is very bad, everytime i need to destroy the vCenter HA and redeploy the installation. It takes hours to copy each vCenter, because the space of each machine uses 440 GB. (And why must the witness copy all the data?)

I my view a simple installation is:

Active and passive in a HA cluster and the witness on a 3rd separate host with a connection to each host of the HA cluster.

I'm tired of using the advanced setup...

0 Kudos
Raudi
Expert
Expert

Now i'm confused. With the HTML 5 client i'm getting this error when selecting a single ESXi host for the witness:

message1.jpg

I think the witness must be in the same HA/DRS Cluster like the active and passive appilance.

But when trying the same with the old flash client:

message2.jpg

But this i currently can't try, because here got a diffent error when selecting the location for the passive node, that i don't get in the HTML5 client:

message3.jpg

Perhaps i try to create 2 new Datastores which are not in the cluster. And i have a case open, i hope they can help me with this...

0 Kudos
daphnissov
Immortal
Immortal

So take its datastore out of your datastore cluster because that's not supported.

0 Kudos
Raudi
Expert
Expert

That isn't possible, because we have a PowerShell script which runs every night, it lists the VM's which are stores on the Datastore Cluster in datacenter A and it lists all VM's which are stored in the Datastore Cluster from datacenter B. With this informations is a VM group filled for VM's wich should run in datacenter A and the same for datacenter B.

I will not change something here.

As i wrote, i will create 2 new datastores for the vCenter and test... But this week i'm very busy...

0 Kudos
daphnissov
Immortal
Immortal

0 Kudos
Raudi
Expert
Expert

Ok the deployment with the flash client has worked!

Active and passive node in the same HA Cluster and whitness on a single host in the same HA network and managed by the same vCenter.

I had opend a case as feature request, the support has forward this.

Why is the setup of vCenter HA in the H5 client so different to the flash client? I can say here some differences:

1. Advanced Setup:

  • Flash: Here the deployment is in 2 steps, the wizard must be paused after network setup, i must clone the passive and witness node, have the chance to modify the network and when finished i can finish the wizard.
  • HTML5: Single step wizard, my tests with the advanced configuration always failed.

2. Std. Setup Datastores:

  • Flash: I can't select a datastore which is part of a datastore cluster for the passive node.
  • HTML5: I can select a datastore which is part of a datastore cluster for the passive node.

3. Std. Setup Resources

  • HTML5: I can't select a host outside the HA/DRS Cluster for the whitness.
  • Flash: I can select a single host outside the HA/DRS Cluster for the witness.

For the moment i'm happy to found a working way to istall vCenter HA...

0 Kudos