kmoses
Contributor
Contributor

vCenter Client Plugin 6.0 Error on OS X

I've been unable to get the client plugin working in chrome or firefox despite following the guidance here and updating the vcenter installation:

VMware KB: After updating Google Chrome to version 45 or later, the vSphere Web Client Integration P...

Here is the error log after attempting to start a web session:

[2015-12-05 21:43:14] [INFO] App Path: /Applications/VMware Client Integration Plug-in.app/Contents/Library/vmware-csd

[2015-12-05 21:43:14] [INFO] Service Dir: /Applications/VMware Client Integration Plug-in.app/Contents/Library

[2015-12-05 21:43:14] [UNKN] Client Support Daemon Version: 6.0.0, Build # 2994041, Session ID # yRjI-tCzc-hGrK-fxxg

[2015-12-05 21:43:14] [INFO] Starting Secure Web Socket Server on port 8093

[2015-12-05 21:43:14] [INFO] Starting Secure Web Socket Server on port 50100

[2015-12-05 21:43:14] [ERRO] Web Socket Server [50100] Terminated With Exception: resolve: Host not found (authoritative)

[2015-12-05 21:43:14] [ERRO] Web Socket Server [8093] Terminated With Exception: resolve: Host not found (authoritative)

[2015-12-05 21:43:14] [ERRO] Lookup server exited with an error, shutting down session server.

[2015-12-05 21:43:16] [WARN] Session keep alive is not supported by client.

[2015-12-05 21:43:16] [INFO] Process exiting.

I found what appears to be an erroneous absolute path reference for a library used by the plugin binary:

$ ./vmware-csd

dyld: Library not loaded: /build/toolchain/mac32/openssl-1.0.1m/lib/libcrypto.1.0.1.dylib

  Referenced from: /Applications/VMware Client Integration Plug-in.app/Contents/Library/./lib/libssl.1.0.1.dylib

  Reason: image not found

Trace/BPT trap: 5


I manually corrected this error by creating the expected directory as a temp solution and got the plugin to run manually, it failed with a session error which makes sense given I wasn't calling it from the browser. 


$ ./vmware-csd

[2015-12-05 21:42:24] [INFO] Using settings file "/Users/ethernaut/VMware/CIP/csd/config/vSphereClientSupport-settings.js"

[2015-12-05 21:42:24] [INFO] Command Line: ./vmware-csd

[2015-12-05 21:42:24] [INFO] Service Dir: /Applications/VMware Client Integration Plug-in.app/Contents/Library/.

[2015-12-05 21:42:24] [ERRO] Fatal Error: A sessionId is required.

Press ENTER to exit...

[2015-12-05 21:42:27] [ERRO] Exit with error code 1


This didn't change the anything for the above error log and the plugin still fails to properly load in the browser.  Any thoughts on what to try next?  I came across this post that mentions permission errors, but it only list the relevant Windows locations.


VMware KB: Troubleshooting the vSphere 6.0 Client Integration Plugin when it fails to function


26 Replies
jamesbowling
VMware Employee
VMware Employee

I am seeing the exact same issue here on my stuff as well.

James B. | Blog: http://www.vSential.com | Twitter: @vSential --- If you found this helpful then please awards helpful or correct points accordingly. Thanks!
0 Kudos
Spherics123
Contributor
Contributor

I was able to get an OVF import to work on Mac OSX 10.11.2 (El Capitan), Chrome 47.0.2526.106 (64-bit) after much trial and error:


Create symlinks for the needed signed libraries from the Application bundle into /build/toolchain/mac32/openssl-1.0.1m/lib/

Very similar steps from: mac osx - Why isn't VMware Client Integration plugin running on Mac OS X 10.11? - Server Fault

NOTE: We are copying from /Library/lib instead of /Framework

$ sudo mkdir -pv /build/toolchain/mac32/openssl-1.0.1m/lib
$ cd /build/toolchain/mac32/openssl-1.0.1m/lib
$ sudo ln -s /Applications/VMware\ Client\ Integration\ Plugin.app/Contents/Library/lib/libssl.1.0.1.dylib
$ sudo ln -s /Applications/VMware\ Client\ Integration\ Plugin.app/Contents/Library/lib/libcrypto.1.0.1.dylib

Copy the signed copies of the libraries into the Frameworks folder from LIbraries/lib folder:

sudo cp /Applications/VMware\ Client\ Integration\ Plug-in.app/Contents/Library/lib/libssl.1.0.1.dylib /Applications/VMware\ Client\ Integration\ Plug-in.app/Contents/Frameworks/libssl.1.0.1.dylib

sudo cp /Applications/VMware\ Client\ Integration\ Plug-in.app/Contents/Library/lib/libcrypto.1.0.1.dylib /Applications/VMware\ Client\ Integration\ Plug-in.app/Contents/Frameworks/libcrypto.1.0.1.dylib


Re-run the vmware-csd-installer:

sudo /Applications/VMware\ Client\ Integration\ Plug-in.app/Contents/Library/vmware-csd-installer --install

After these steps are complete you should be able to run an OVF import from Chrome.

However, the vmware-csd-installer still gets the following error trying to update Firefox to allow the new certificates:

Install certificate into FireFox cert store

Found profiles Dir=/Users/<user>/Library/Application Support/Firefox/Profiles/

Unable to find FireFox profiles folder

[2016-01-05 10:44:23] [ERRO] Certificate failed to install to Firefox with error code ffffffff

If anyone has anything to add for Firefox, please feel free to share.

devros69
Contributor
Contributor

This sort of worked for me, but the latest installer installs openssl-1.0.1p rather than 1.0.1m

Ran into the same problem with firefox.

bash-3.2# ./vmware-csd-installer --install

[2016-01-28 16:51:59] [INFO] Using settings file "/Applications/VMware Client Integration Plug-in.app/Contents/Library/./data/config/vSphereClientSupport-settings.js"

[2016-01-28 16:51:59] [INFO] Installer Dir: /Applications/VMware Client Integration Plug-in.app/Contents/Library/.

[2016-01-28 16:51:59] [INFO] Self-Signed Certificate already exists.

[2016-01-28 16:51:59] [INFO] Generating random data file...

[2016-01-28 16:51:59] [INFO] Starting sync process: /Applications/VMware Client Integration Plug-in.app/Contents/Library/./openssl

[2016-01-28 16:51:59] [INFO] unknown option -5

ecparam [options] <infile >outfile

where options are

-inform arg       input format - default PEM (DER or PEM)

-outform arg      output format - default PEM

-in  arg          input file  - default stdin

-out arg          output file - default stdout

-noout            do not print the ec parameter

-text             print the ec parameters in text form

-check            validate the ec parameters

-C                print a 'C' function creating the parameters

-name arg         use the ec parameters with 'short name' name

-list_curves      prints a list of all currently available curve 'short names'

-conv_form arg    specifies the point conversion form

                   possible values: compressed

                                    uncompressed (default)

                                    hybrid

-param_enc arg    specifies the way the ec parameters are encoded

                   in the asn1 der encoding

                   possible values: named_curve (default)

                                    explicit

-no_seed          if 'explicit' parameters are chosen do not use the seed

-genkey           generate ec key

-rand file        files to use for random number input

-engine e         use engine e, possibly a hardware device

[2016-01-28 16:51:59] [INFO] DER file already exists.

[2016-01-28 16:51:59] [INFO] Server pem file already exists.

2016-01-28 16:51:59.356 vmware-csd-installer[4310:723002] SecKeychainSetPreferenceDomain: 0

2016-01-28 16:51:59.357 vmware-csd-installer[4310:723002] fingerpring: 5F 06 EF 43 47 51 4D 9D 61 E9 26 53 84 5E 8A FF 09 DD 53 CE

2016-01-28 16:51:59.368 vmware-csd-installer[4310:723002] Certificate exists, will update

2016-01-28 16:51:59.391 vmware-csd-installer[4310:723002] Change Trust settings

Install certificate into FireFox cert store

Found profiles Dir=/Users/xxx/Library/Application Support/Firefox/Profiles/

Unable to find FireFox profiles folder

[2016-01-28 16:51:59] [ERRO] Certificate failed to install to Firefox with error code ffffffff

[2016-01-28 16:51:59] [INFO] Changes to the hosts file were successful.

[2016-01-28 16:51:59] [INFO] Changes to the hosts file were successful.

0 Kudos
JackMac4
Enthusiast
Enthusiast

This still doesn't fix things for me. It does allow me to reinstall the plugin, but the plugin doesn't work on the latest chrome 48 for mac, nor does it work on Chrome 43 for mac which I have as well.

---- Jack McMichael | Sr. Systems Engineer VMware End User Computing Contact me on Twitter @jackwmc4
0 Kudos
SavkoorSuhas
Expert
Expert

This worked for me. Couple of operations like upload to DS and deploy OVF worked.

However, Windows Session Credentials does not work and Download CIP message still remain.


Suhas

If you found this or any other answer useful please consider the use of the Helpful or Correct buttons to award points. Don't Backup. Go Forward! Rubrik Peek into my Website: http://www.virtuallypeculiar.com
0 Kudos
matt948
Enthusiast
Enthusiast

I'm having the same issue, Chrome 48 on 10.11.3

However, the fix posted above is not working for me

bash-3.2$ sudo mkdir -pv /build/toolchain/mac32/openssl-1.0.1m/lib 

bash-3.2$ cd /build/toolchain/mac32/openssl-1.0.1m/lib

bash-3.2$ sudo ln -s /Applications/VMware\ Client\ Integration\ Plugin.app/Contents/Library/lib/libssl.1.0.1.dylib 

bash-3.2$ sudo ln -s /Applications/VMware\ Client\ Integration\ Plugin.app/Contents/Library/lib/libcrypto.1.0.1.dylib 

bash-3.2$ sudo cp /Applications/VMware\ Client\ Integration\ Plug-in.app/Contents/Library/lib/libssl.1.0.1.dylib /Applications/VMware\ Client\ Integration\ Plug-in.app/Contents/Frameworks/libssl.1.0.1.dylib  

bash-3.2$ sudo cp /Applications/VMware\ Client\ Integration\ Plug-in.app/Contents/Library/lib/libcrypto.1.0.1.dylib /Applications/VMware\ Client\ Integration\ Plug-in.app/Contents/Frameworks/libcrypto.1.0.1.dylib  

bash-3.2$

bash-3.2$ sudo /Applications/VMware\ Client\ Integration\ Plug-in.app/Contents/Library/vmware-csd-installer --install 

dyld: Library not loaded: /build/toolchain/mac32/openssl-1.0.1m/lib/libcrypto.1.0.1.dylib

  Referenced from: /Applications/VMware Client Integration Plug-in.app/Contents/Library/lib/libssl.1.0.1.dylib

  Reason: image not found

0 Kudos
jhuhmann
Contributor
Contributor

Yours might not be working because the symbolic links you're making are missing the hyphen from ...plug-in.app. Also, the openssl-1.0.1m folder has changed to openssl-1.0.1p in later installers.

After I made those changes I was able to run the installer though it still fails to install the certificate in firefox.

0 Kudos
MilenX
Contributor
Contributor

I used a slightly more elegant approach found here: http://lluad.com/blog/2015/11/21/fixing-os-x-vmware-client-integration-6-dot-0/

for i in *.dylib ; do echo $i ;  otool -L $i | grep toolchain ; done

Instead of creating symlinks to satisfy wrong link paths in the shared objects, I changed the paths inside the libraries using the tool "install_name_tool"

The exact commands I used were:

cd /Applications/VMware\ Client\ Integration\ Plug-in.app/Contents/Library/lib/

sudo install_name_tool -change "/build/toolchain/mac32/openssl-1.0.1m/lib/libcrypto.1.0.1.dylib" "@loader_path/libcrypto.1.0.1.dylib" libssl.1.0.1.dylib

cd /Applications/VMware\ Client\ Integration\ Plug-in.app/Contents/Library/

sudo install_name_tool -change "/build/toolchain/mac32/openssl-1.0.1m/lib/libssl.1.0.1.dylib" "@executable_path/lib/libssl.1.0.1.dylib" openssl

sudo install_name_tool -change "/build/toolchain/mac32/openssl-1.0.1m/lib/libcrypto.1.0.1.dylib" "@executable_path/lib/libcrypto.1.0.1.dylib" openssl

sudo "/Applications//VMware Client Integration Plug-in.app/Contents/Library/vmware-csd-installer" --install

lusid2
Enthusiast
Enthusiast

Hitting this also on 6.0U2, but none of the hacks seem to work. CIP is broken on all browsers in OSX.  Abandoning the flash client... again...

MilenX
Contributor
Contributor

There where I typo in my posts, which is fixed now.

Also on some installation the libssl version is 1.0.1p (mine is 1.0.1m), which changes some paths in the command.

Here what is the commands my colleague has to run to make it work:

cd "/Applications/VMware Client Integration Plug-in.app/Contents/Library/lib/"

sudo install_name_tool -change "/build/toolchain/mac32/openssl-1.0.1p/lib/libcrypto.1.0.1.dylib" "@loader_path/libcrypto.1.0.1.dylib" libssl.1.0.1.dylib

cd ..

sudo install_name_tool -change "/build/toolchain/mac32/openssl-1.0.1p/lib/libssl.1.0.1.dylib" "@executable_path/lib/libssl.1.0.1.dylib" openssl

sudo install_name_tool -change "/build/toolchain/mac32/openssl-1.0.1p/lib/libcrypto.1.0.1.dylib" "@executable_path/lib/libcrypto.1.0.1.dylib" openssl

sudo ./vmware-csd-installer  --install

lusid2
Enthusiast
Enthusiast

That actually worked.  Thanks. 

0 Kudos
DimYordanov
Enthusiast
Enthusiast

Can you actually deploy ovf template?

After I made the changes MilenXMilenX suggested the browser finds the integration plugin, but when I select browse to find the ovf the plugin crashes...

0 Kudos
RohitParashar
VMware Employee
VMware Employee

This issue is happening only on  El Capitan(OSX 10.11 onward ) upgrade of Mac. System Integrity Protection (rootless) is causing this issue. SIP is a new feature enabled in the Mac to prevent Mac OS X compromise by malicious code.

To workaround this issue i performed following steps:

1) Reboot the el-capitan in recovery mode

2) Disable the SIP( System Integrity Protection) using following command on terminal "csrutil disable; reboot"

3) Install the CIP

4) Reboot the el-capitan in recovery mode.

5) Run following command on terminal "csrutil enable"

6) Reboot the Mac

After that i was able to launch CIP on the Mac without any problem.

Thanks,

Rohit

Virtuosx
Contributor
Contributor

Hi Rohit,

In the past weeks I found this solution working for several installation and configuration issues with (non-vmware) programs. Unfortunately your workaround did not help in this case. I tried U1 and U2 client plugin.

Regards,

Robert

0 Kudos
Virtuosx
Contributor
Contributor

Hi Milenx

Your workaround got me one step further (the image error is gone and ff certificate is ok now).  I tried U1 and U2 client plugin but I still can't get further getting this working on OSX 10.11.4

my csd.log ;

[2016-04-06 15:48:56] [INFO] App Path: /Applications/VMware Client Integration Plug-in.app/Contents/Library/vmware-csd

[2016-04-06 15:48:56] [INFO] Service Dir: /Applications/VMware Client Integration Plug-in.app/Contents/Library

[2016-04-06 15:48:56] [UNKN] Client Support Daemon Version: 6.0.0, Build # 2994041, Session ID # UU1V-5acK-3ibJ-ACYr

[2016-04-06 15:48:56] [INFO] Starting Secure Web Socket Server on port 8093

[2016-04-06 15:48:56] [INFO] Started Secure Web Socket Server on port 8093

[2016-04-06 15:48:56] [INFO] Starting Secure Web Socket Server on port 50100

[2016-04-06 15:48:56] [INFO] Started Secure Web Socket Server on port 50100

[2016-04-06 15:48:57] [INFO] Socket failed: 8093

[2016-04-06 15:48:59] [INFO] Socket failed: 8093

[2016-04-06 15:49:00] [INFO] Socket failed: 8093

[2016-04-06 15:49:00] [INFO] Socket failed: 8093

[2016-04-06 15:49:01] [INFO] Socket failed: 8093

[2016-04-06 15:49:03] [INFO] Socket failed: 8093

[2016-04-06 15:49:05] [INFO] Socket failed: 8093

[2016-04-06 15:49:09] [INFO] Socket failed: 8093

[2016-04-06 15:49:13] [INFO] Start FF check:

[2016-04-06 15:49:13] [INFO] "/Applications/VMware Client Integration Plug-in.app/Contents/Library/vmware-csd-installer" --checkFF

[2016-04-06 15:49:14] [INFO] Socket failed: 8093

[2016-04-06 15:49:22] [INFO] Socket failed: 8093

[2016-04-06 15:49:27] [ERRO] Login timed out, shutting down servers.

[2016-04-06 15:49:27] [INFO] Stop called on web socket: 8093

[2016-04-06 15:49:27] [INFO] Stop called on web socket: 50100

[2016-04-06 15:49:27] [INFO] Web Socket Server [8093] Terminated With no error code

[2016-04-06 15:49:27] [INFO] Web Socket Server [50100] Terminated With no error code

[2016-04-06 15:49:27] [INFO] Process exiting.

and my wss_8093.log

[2016-04-06 15:48:57] [info] asio async_read_at_least error: asio.ssl:336151576 (tlsv1 alert unknown ca)

[2016-04-06 15:48:57] [fatal] error in handle_read_handshake: Generic TLS related error

[2016-04-06 15:48:57] [info] asio async_shutdown error: system:32 (Broken pipe)

[2016-04-06 15:48:57] [disconnect] Failed: Generic TLS related error

[2016-04-06 15:48:59] [info] asio async_read_at_least error: asio.ssl:336151576 (tlsv1 alert unknown ca)

[2016-04-06 15:48:59] [fatal] error in handle_read_handshake: Generic TLS related error

[2016-04-06 15:48:59] [info] asio async_shutdown error: system:32 (Broken pipe)

[2016-04-06 15:48:59] [disconnect] Failed: Generic TLS related error

[2016-04-06 15:49:00] [info] asio async_read_at_least error: asio.ssl:336151576 (tlsv1 alert unknown ca)

[2016-04-06 15:49:00] [fatal] error in handle_read_handshake: Generic TLS related error

[2016-04-06 15:49:00] [disconnect] Failed: Generic TLS related error

[2016-04-06 15:49:00] [info] asio async_read_at_least error: asio.ssl:336151576 (tlsv1 alert unknown ca)

[2016-04-06 15:49:00] [fatal] error in handle_read_handshake: Generic TLS related error

[2016-04-06 15:49:00] [disconnect] Failed: Generic TLS related error

[2016-04-06 15:49:01] [info] asio async_read_at_least error: asio.ssl:336151576 (tlsv1 alert unknown ca)

[2016-04-06 15:49:01] [fatal] error in handle_read_handshake: Generic TLS related error

[2016-04-06 15:49:01] [info] asio async_shutdown error: system:32 (Broken pipe)

[2016-04-06 15:49:01] [disconnect] Failed: Generic TLS related error

[2016-04-06 15:49:03] [info] asio async_read_at_least error: asio.ssl:336151576 (tlsv1 alert unknown ca)

[2016-04-06 15:49:03] [fatal] error in handle_read_handshake: Generic TLS related error

[2016-04-06 15:49:03] [info] asio async_shutdown error: system:32 (Broken pipe)

[2016-04-06 15:49:03] [disconnect] Failed: Generic TLS related error

[2016-04-06 15:49:05] [info] asio async_read_at_least error: asio.ssl:336151576 (tlsv1 alert unknown ca)

[2016-04-06 15:49:05] [fatal] error in handle_read_handshake: Generic TLS related error

[2016-04-06 15:49:05] [info] asio async_shutdown error: system:32 (Broken pipe)

[2016-04-06 15:49:05] [disconnect] Failed: Generic TLS related error

[2016-04-06 15:49:09] [info] asio async_read_at_least error: asio.ssl:336151576 (tlsv1 alert unknown ca)

[2016-04-06 15:49:09] [fatal] error in handle_read_handshake: Generic TLS related error

[2016-04-06 15:49:09] [disconnect] Failed: Generic TLS related error

[2016-04-06 15:49:14] [info] asio async_read_at_least error: asio.ssl:336151576 (tlsv1 alert unknown ca)

[2016-04-06 15:49:14] [fatal] error in handle_read_handshake: Generic TLS related error

[2016-04-06 15:49:14] [info] asio async_shutdown error: system:32 (Broken pipe)

[2016-04-06 15:49:14] [disconnect] Failed: Generic TLS related error

[2016-04-06 15:49:22] [info] asio async_read_at_least error: asio.ssl:336151576 (tlsv1 alert unknown ca)

[2016-04-06 15:49:22] [fatal] error in handle_read_handshake: Generic TLS related error

[2016-04-06 15:49:22] [disconnect] Failed: Generic TLS related error

Can you get me any further ?

Thanks in advance

0 Kudos
MilenX
Contributor
Contributor

My suggestion is to first completely delete Client Integration Plugin and start over with the install and then with the fix.

The error "tlsv1 alert unknown ca"   I  think can be solved with downloading the root certificate from the vCenter and add it as trusted in KeyChain:

Open the https://vcenter-address/ and click "Download trusted root CA certificates" link. Then rename the dowloaded file with .zip extension., after unzip rename the file with .0 extension to .crt and add the root CA to your KeyChain.

However after all fixes and reinstallations my Client Integration Plugin starts, but I get random crashes and hangs from CIP and I am unable to complete even simple .ova deploy.

We are now upgrading to vCenter Server 6.0 Update 2 to see if the client works better there. I will write back with the results.

0 Kudos
joncolchis
Contributor
Contributor

I'm on OS X 10.9.5 running Chrome 49.0.2623.110 and experiencing similar problems.

Viewing the JavaScript console from the VCSA Web Client reveals:

"WebSocket connection to 'wss://vmware-localhost:8093/' failed: Error in connection establishment: net::ERR_CONNECTION_REFUSED"

I am running the latest VCSA and downloaded the Client Integration pkg from there. I have applied the link workarounds posted by MilenX as well.

Any ideas?

0 Kudos
lusid2
Enthusiast
Enthusiast

As others have said, even when its installed it crashes if you try to use it.  Simple OVAs can be pushed with the host client or ovftool, otherwise oldskool still works: shared folders->fusion->windowsVM->dotnet client->vcenter.  Its ugly, but if CIP could actually be fixed they would have fixed it by now. 

Virtuosx
Contributor
Contributor

Thanks fir the feedback, as we are running the latest version (6.0U2) and spend an awfull lot of time getting it running on OSX I guess I'll wait for the next release before trying getting it to work again.

0 Kudos