salshawwa
Contributor
Contributor

vCenter Appliance Update Failing

Jump to solution

anyone having issues upgrading vCenter Appliance 6.5.0.21000 Build Number 8815520 to 6.5.0.22000 Build Number 9451637 that was released on August 14th 2018 ?

i tried upgrading two non-production vCenter Appliances  and both failed to install the update/upgrade.


1 Solution

Accepted Solutions
Vijay2027
Expert
Expert

Looks like root password is expired

Log:

2018-08-16T07:43:01.228 [83559]DEBUG:vmware.vherd.base.software_update:Failed to update package

out=Preparing...                          ########################################

error=You are required to change your password immediately (root enforced)

usermod: PAM: Authentication token is no longer valid; new one required

error: %prein(vmware-imagebuilder-6.5.0-9451637.x86_64) scriptlet failed, exit status 1

error: vmware-imagebuilder-6.5.0-9451637.x86_64: install failed

You are required to change your password immediately (root enforced)

useradd: PAM: Authentication token is no longer valid; new one required

Putty into vCSA and reset root password and retry upgrade.

# passwd root.

View solution in original post

9 Replies
Vijay2027
Expert
Expert

Attach software-packages.log from /var/log/vmware/applmgmt.

0 Kudos
pcfarrartt
Contributor
Contributor

I've got the exact same problem. I tried updating via the ISO too and that didn't work.

0 Kudos
Vijay2027
Expert
Expert

Need more information.

Attach software-packages.log from /var/log/vmware/applmgmt.

0 Kudos
pcfarrartt
Contributor
Contributor

What's the easiest way to get that log file?

0 Kudos
Vijay2027
Expert
Expert

putty into vCSA and run the below command:

chsh -s /bin/bash root

and use winscp utility to connect to vCSA and copy log file to your local machine and attach it to the thread.

pcfarrartt
Contributor
Contributor

I've attached the file.

0 Kudos
Vijay2027
Expert
Expert

Looks like root password is expired

Log:

2018-08-16T07:43:01.228 [83559]DEBUG:vmware.vherd.base.software_update:Failed to update package

out=Preparing...                          ########################################

error=You are required to change your password immediately (root enforced)

usermod: PAM: Authentication token is no longer valid; new one required

error: %prein(vmware-imagebuilder-6.5.0-9451637.x86_64) scriptlet failed, exit status 1

error: vmware-imagebuilder-6.5.0-9451637.x86_64: install failed

You are required to change your password immediately (root enforced)

useradd: PAM: Authentication token is no longer valid; new one required

Putty into vCSA and reset root password and retry upgrade.

# passwd root.

View solution in original post

pcfarrartt
Contributor
Contributor

Thanks for the help! Worked as soon as I changed the password.

0 Kudos
dalexiev
Enthusiast
Enthusiast

changing the password from VCSA console solved the issue. thank you

0 Kudos