mboucher8789
Contributor
Contributor

vCenter 7 - unable to upgrade VMWare Tools

Hi,

We are running vCenter 7 and VM's with ESXi 7.0.

When trying to upgrade VMWare tools on some VMs and we are receiving this error: Scan or remediation is not supported on server because of unsupported OS Microsoft Windows Server 2019 (64-bit).

The VMs were fresh creations in vCenter 7 and installed with Server 2019 from the start.

Any ideas how to fix this? Other than just installing the tools manualy on each VM...

Thanks,
Michael

0 Kudos
5 Replies
Ajay1988
VMware Employee
VMware Employee

Is the VM hardware version at 17  or 18 and OS   selected 2019 ? If not update  VM hardware version first and then the OS . Later try Tools update

If you think your queries have been answered
Mark this response as "Correct" or "Helpful".

Regards,
AJ
0 Kudos
mboucher8789
Contributor
Contributor

VM hardware version is 17 and OS selected is 2019. I set one machine to auto update tools on reboot and it worked, seems just the remediatio process is broken?

0 Kudos
Ajay1988
VMware Employee
VMware Employee

Cool. Let me check this in a lab and report back

If you think your queries have been answered
Mark this response as "Correct" or "Helpful".

Regards,
AJ
0 Kudos
Ajay1988
VMware Employee
VMware Employee

It worked for me. I am on the latest ESXi and VCSA versions on 7.0   . One difference is HW version is 18 for me.   Try with HW 18 . Else   we have to check   vum logs .

If you think your queries have been answered
Mark this response as "Correct" or "Helpful".

Regards,
AJ
0 Kudos
BMachiavello
Contributor
Contributor

Hi,

we have the same problem for Windows 2022 VM,  hardware version 19.

is it normal ?

vsphere 7.03 last update

 

0 Kudos