jobee1
Enthusiast
Enthusiast

vCenter 7 Cluster has EVC enabled but added hosts show EVC disabled

Good afternoon, 

My vCenter 7.0.2 server cluster shows that EVC is enabled, but any added hosts show that EVC Mode is disabled. I have added four hosts and removed and re-added a couple of them but no joy. I've tried powering off the host for 30 seconds while it's in the cluster and then restarting it but no joy. I must be missing something about this issue because just about everything I find while Googling it tells me how to configure EVC in a cluster. Any ideas, suggestions, or recommendations would be greatly appreciated. 

Thanks, 

Joe B

0 Kudos
5 Replies
jobee1
Enthusiast
Enthusiast

Ok, here's something I just noticed - when I click on the cluster, then click on Hosts over to the right, and then click on the Hosts button next to Resource Pools I see zero hosts. Apparently right-clicking on cluster and then clicking on Add Hosts... isn't how I'm supposed to add hosts. I'm going to see if there's a different way to add hosts to a cluster in vCenter 7. I'll let you all know what I find out. 

Thanks, 

Joe B 

0 Kudos
a_p_
Leadership
Leadership

Add Hosts ... is definitely a correct way to add new hosts to a vCenter Server inventory. Please note, that adding new hosts directly into a cluster requires that the host is in Maintenance Mode. If the host has already been added to the inventory, you can drag&drop it into your EVC enabled cluster, assuming that the hosts meets the EVC requirements, and no VMs (with CPU features higher than the EVC mode allows) are running on that host.

André

0 Kudos
Arthos
Enthusiast
Enthusiast

Jobee,

There are 2 things here,

1. Hosts not showing EVC mode.
2. No hosts in resource pool at the location you pointed.


Let's try these.

1. create a cluster C1 in your vcenter.
2. enable EVC baseline.
3. Add hosts to your cluster.
4. check EVC mode in summary -> configuration tab [when you click on hosts]


For second problem,

 cluster -> hosts -> resource pool , will only show resource pool present in that cluster. It will not show hosts.
You can confirm it by enabling DRS in your cluster and the creating a resource pool in the cluster.

- If response helps, consider marking it as helpful

0 Kudos
jobee1
Enthusiast
Enthusiast

After some more poking around under the hood I have learned that my vCenter had DRS enabled. That didn't bother me, but when I checked my ESXi licenses I saw that they DON'T have DRS. I turned off DRS on vCenter and now three of my four hosts are in the cluster with no errors. I like simple fixes, but I'd have liked DRS in my ESXi licenses. Oh well, that's what I get for not looking more closely at the documentation. Now if you'll excuse me I have to add my VMs to my cluster. Have a good weekend. 

Thanks and caveat emptor,  

Joe B 

 

0 Kudos
Arthos
Enthusiast
Enthusiast

Glad to help. let me know if you face any issues.

0 Kudos