bigideaguys
Contributor
Contributor

vCenter 7 Appliance Setup wizard won't go past step 3

At a total loss why the "next" button is greyed out in step 3 of the setup wizard. (second screen cap below).

Note - the button is greyed out when the 3rd step loads, doesn't matter what info I put in the form boxes. Everything in step 2 is correct though.

There are no error messages and everything seems to be working fine otherwise. ESXi 7U3 setup went perfectly, DNS forward/reverse set up. The IP resolves, I am doing this via a web browser using the FQDN URL since same thing happens using the setup.exe from the DVD. I've tried this half a dozen times with full wipes and re-installs of ESXi and vCenter appliance and it hangs here every single time.

  

0 Kudos
4 Replies
IRIX201110141
Champion
Champion

A small layer8 problem 😉
You have to specify the SSO Domain. The wizzard only showing a example "vsphere.local". Insert the same value again and you will see the difference in font color.

Regards,
Joerg

bigideaguys
Contributor
Contributor

Wow... I feel like an idiot now <facepalm>. Thank you... sometimes because I always deal with complicated things, the simple things are so obvious it's embarrassing, and this is one of those times. To think I spent over a day re-installing everything multiple times... ugh. I may have well gone on a snipe hunt lol!

Cheers and thank you again @IRIX201110141 !

0 Kudos
IRIX201110141
Champion
Champion

Hehehhehe.

Its a example of poor GUI design here. A red asterix should or something else should indicate that the user have to enter some important configuration here.

Regards,
Joerg

0 Kudos
bigideaguys
Contributor
Contributor

I have done tons of web development before so I am a bit tough on myself. But an even better indicator is changing the default text to something like: For example: vsphere.local so you still leave the placeholder text but also tell the end user it is placeholder text.

I have found with a lot of aspects to VMWare software and other advanced technology tools in any subject, they do NOT cater to people learning. And I agree that you do learn a lot when having to troubleshoot like this, and feel embarrassed (I'm sure not forgetting this again!) but that still is no excuse for poor UI design when your example is the exact best practice data to use in a form field. There is a difference between dumbing things down vs poor UI design.

Thank you again Joerg!

0 Kudos