Caffeine_Free
Enthusiast
Enthusiast

vCenter 5.5 Client Integration plug-in not working under IE and Chrome

Has anyone encountered a problem where the Client Integration Plug-in doesn't work even though it has been installed? I have upgraded vCenter to 5.5 (from 5.0) and I am seeing the same problem across multiple PCs. When connecting to the Web Client the option to log ins using Windows authentication is grayed out. Also the option to open a VM console from the Actions menu is grayed out. I can launch the console from the Summary tab but it takes a long time for it to come up and show the desktop. When the console finally opens I am prompted to download the Client Integration Plug-in, even though it is already installed.

I have this problem using IE10, IE11 and Chrome. Opera on the other hand works fine.

Any thoughts and suggestions?

Thanks

37 Replies
crawfordm
Expert
Expert

Try to uninstall the plug-in and then re-install

------------------------------------------------------------------ If you found this answer useful please consider the use of the Helpful or Correct buttons to award points. Thanks, Marc Crawford CCNA, MCSE, MCTS, A+, Net+, Sec +, VCA-WM, VCA-DCV, VCA-Cloud, VCA-NV, VCP-NV, VCP-DCV, VCP, VCAP5-DCA http://gplus.to/marccrawford http://blog.marccrawford.com @uber_tech_geek
0 Kudos
mahantesh_dinda
Contributor
Contributor

It is a known issue with regard to IE11 and above for vCenter Server 5.x & 5.5 which is stated in VC5.1 Update 2 release notes under Known Issues section.

vCenter Server 5.1 Update 2 Release Notes

Caffeine_Free
Enthusiast
Enthusiast

Interesting. Why isn't this listed as a problem in vCenter 5.5 release notes? Perhaps because according to VMware support it is not a problem. I contacted VMware support and was told that while IE11 isn't officially supported the plug-in should work. The tech tested it in his lab and told me that all was fine. I am so happy that this works in his test environment. :smileyangry:

Also, I was able to make it work in IE10 and Chrome after a bit of fiddling around with the add-in security settings in each of the browsers.

0 Kudos
virtualizacao
Contributor
Contributor

0 Kudos
Caffeine_Free
Enthusiast
Enthusiast

Thanks virtualizacao but that did not make a difference.

0 Kudos
Caffeine_Free
Enthusiast
Enthusiast

Here I am 3 months later and still cannot get the plug-in working in IE11. I've basically given up at this point and switched over to Opera as it seems to work fine in the browser.

0 Kudos
NvR4GeT
Enthusiast
Enthusiast

Something of interest. I found with Google Chrome I would download the Plug In, close the browser out and then "Run As Administrator" on the Plug-In installer. This seems to work great with Chrome, but not in IE11. I am still having problems myself with IE11 and vSphere 5.5 Web Client Integration Tools. Not sure why they haven't addressed this quicker? Hopefully VMware will resolve this, it makes it much more difficult to deploy ova files from Web Client as were advised to use the Web Client and not the vSphere Client.

chris4136
Contributor
Contributor

Hey guys, I'm having the same issue with IE11 under Windows.  So this is not an isolated event on VSphere 5.5.  No troubles having it work on Firefox 29.

I don't even want to mention in my Mac.... It would not work for three browsers (although I still have to look into version compatibility.

-Chris

0 Kudos
BeardedMallard
Contributor
Contributor

I was able to get it to work in Firefox 30 by going to the Add-Ons Manager, Plugins, and setting it to Always Activate.

JohnYork
Contributor
Contributor

Thanks BeardedMallard!  I've been unable to get IE11 or Chrome to run the integration plugin, but this worked!!!!

0 Kudos
ErbsSrServTech
Contributor
Contributor

I have not been able to get it to work in IE11, yet.  It works fine for me in Chrome (Version 35.0.1916.153 m).  I would like to be able to use it in Waterfox, but have yet to find how I can install the plug-in there.

0 Kudos
FoaRyan
Contributor
Contributor

Is VMware going to address this issue? I'm starting to get quite frustrated.

0 Kudos
malhi_o
Enthusiast
Enthusiast

I am a big fan of Google chrome. But Firefox is more compatible with VMware products such as vCD and vCAC.

0 Kudos
umber2
Contributor
Contributor

Were you ever able to get it to work on your Mac? I have been completely unsuccessful in my efforts to get the console to work in Firefox, Chrome, or Safari on Mac.

0 Kudos
ahbond
Contributor
Contributor

This is exactly the sort of thing that really bothers me about VMware dropping support/development of the original 'Thick Client'

😞

0 Kudos
joe4VMware
Contributor
Contributor

Workaround press F12 in Internet Explorer and choose at Dokument Mode = 7 and at User Agent String IE7

dadalowg2
Enthusiast
Enthusiast

Thanks joe4VMware....

That worked!!!!!

I used 10 instead of 7

0 Kudos
ger1820
Contributor
Contributor

Something of interest. I found with Google Chrome I would download the Plug In, close the browser out and then "Run As Administrator" on the Plug-In installer. This seems to work great with Chrome, but not in IE11. I am still having problems myself with IE11 and vSphere 5.5 Web Client Integration Tools. Not sure why they haven't addressed this quicker? Hopefully VMware will resolve this, it makes it much more difficult to deploy ova files from Web Client as were advised to use the Web Client and not the vSphere Client.

0 Kudos
cjens19
Contributor
Contributor

Ok this is sort of an old post, but I stumbled across it while trying to get the 5.5 Client Integration Plugin working with my client's new 2012 R2 mgmt server, and Google Chrome. I got it to work finally, and wanted to detail the changes I made.

In Chrome, go to

-Settings

-Click "Show Advanced Settings"

-Under Privacy, click the "Content settings..." button

-Scroll down to the Plug-ins sections, and click the "Disable individual plug-ins..." link

-Find these 2 Plug-ins and tick "Always allowed": VMWare Client Support Plug-in, and VMWare Remote Console Plug-in

-Close Chrome and log back into vCenter web client

-The "Use Windows session credentials" box should now be clickable

-Just un-tick the "ask before allowing this site" box so it doesn't bother you again

After doing that, I can now use Chrome to get into consoles and all that. Cheers!!

PS, you may have to allow popups in Chrome for the IP of your vCenter appliance.

-Chris

0 Kudos