VMware Cloud Community
trogne
Enthusiast
Enthusiast
Jump to solution

vCSA vm not started right

After deploying vCSA vm (in workstation 12), and before the first power on, I added those lines to the .vmx :

***

guestinfo.cis.vmdir.password = "mypass!"

guestinfo.cis.appliance.net.addr.family = "ipv4"

guestinfo.cis.appliance.net.addr = "192.168.1.112"

guestinfo.cis.appliance.net.prefix = "24"

guestinfo.cis.appliance.net.mode = "static"

guestinfo.cis.appliance.net.dns.servers = "192.168.1.111"

guestinfo.cis.appliance.net.gateway = "192.168.1.1"

guestinfo.cis.appliance.root.passwd = "mypass!

***

Then, I power on the machine. And I see this :

***

Please visit the following URL to configure this appliance:

http://localhost:

Download support bundle from:

http://localhost:/appliance/support-bundle

Storage initialization failed

***

Based on the tutorial I'm following (he used vCenter 6, not 6.5), I should see this :

***

Download support bundle from :

https://vcsa.nuglab.local:443/appliance/support-bundle

https://192.168.1.112/ (STATIC)

***

My DNS is on. I can resolve vcsa.nuglab.local to 192.168.1.112.

1 Solution

Accepted Solutions
trogne
Enthusiast
Enthusiast
Jump to solution

I think that with vCSA 6.5, the .vmx needed the "guestinfo.cis.appliance.net.pnid"  (Primary Network Identifier).

It works with these settings :

***

guestinfo.cis.deployment.node.type = "embedded"

guestinfo.cis.appliance.net.addr.family = "ipv4"

guestinfo.cis.appliance.net.mode = "static"

guestinfo.cis.appliance.net.pnid = "vcsa.nuglab.local"

guestinfo.cis.appliance.net.addr = "192.168.1.112"

guestinfo.cis.appliance.net.prefix = "24"

guestinfo.cis.appliance.net.gateway = "192.168.1.1"

guestinfo.cis.appliance.net.dns.servers = "192.168.1.111"

guestinfo.cis.appliance.root.passwd = "mypass!"

guestinfo.cis.appliance.ssh.enabled = "True"

guestinfo.cis.deployment.autoconfig = "False"

***

Then, since in 6.5 the config is a 2 stage process, I go here for stage 2 :

https://192.168.1.116:5480

I could also have add the stage 2 options inside the .vmx.

View solution in original post

2 Replies
trogne
Enthusiast
Enthusiast
Jump to solution

I think that with vCSA 6.5, the .vmx needed the "guestinfo.cis.appliance.net.pnid"  (Primary Network Identifier).

It works with these settings :

***

guestinfo.cis.deployment.node.type = "embedded"

guestinfo.cis.appliance.net.addr.family = "ipv4"

guestinfo.cis.appliance.net.mode = "static"

guestinfo.cis.appliance.net.pnid = "vcsa.nuglab.local"

guestinfo.cis.appliance.net.addr = "192.168.1.112"

guestinfo.cis.appliance.net.prefix = "24"

guestinfo.cis.appliance.net.gateway = "192.168.1.1"

guestinfo.cis.appliance.net.dns.servers = "192.168.1.111"

guestinfo.cis.appliance.root.passwd = "mypass!"

guestinfo.cis.appliance.ssh.enabled = "True"

guestinfo.cis.deployment.autoconfig = "False"

***

Then, since in 6.5 the config is a 2 stage process, I go here for stage 2 :

https://192.168.1.116:5480

I could also have add the stage 2 options inside the .vmx.

banothramkumar
Contributor
Contributor
Jump to solution

guestinfo.cis.vmdir.password = "mypass!"

guestinfo.cis.appliance.net.addr.family = "ipv4"

guestinfo.cis.appliance.net.addr = "192.168.1.112"

guestinfo.cis.appliance.net.prefix = "24"

guestinfo.cis.appliance.net.mode = "static"

guestinfo.cis.appliance.net.dns.servers = "192.168.1.111"

guestinfo.cis.appliance.net.gateway = "192.168.1.1"

guestinfo.cis.appliance.root.passwd = "mypass!

 

 

 

HI good afternoon , where should i paste or configure above queries ,can you please let me know

 

Reply
0 Kudos