VMware Cloud Community

unable to remove VM extraConfig entries via ReconfigVM_Task()


Problem description:    

I am trying to add/update/remove my own {key, value} pairs under vm.config.extraConfig via ReconfigVM_Task().  Adding and updates worked

fine on all of my VMs, but removing the entries worked only with some of my VMs.

The vSphere 5.5 SDK documentation vSphere 5.5 Documentation Center state that "If the key is already present, it will be reset with the new

value provided. Otherwise, a new option is added. Keys with empty values will be removed."

The symptom on the VMs where removal action consistently failed is that when I specified keys with empty values,  after completion

of ReconfigVM_Task(), those entries still showed up with empty values, while the expected behaviour is that they should be


On the VMs the removal action consistently worked, after completion of ReconfigVM_Task() for keys with empty values those entries

were completely removed from the VM extra config.  

Both VMs are managed by VCSA,  vCenter 5 Standard, version 5.5.0  Build 1476327

The only difference I could find so far between a VM where the said removal action works, and where it fails, is that
the former is
Compatibility: ESX/ESXi 4.0 and later (VM version 7)    and

the latter  is Compatibility: ESX/ESXi 5.0 and later (VM version 😎


0 Kudos
0 Replies