unable to deploy an ova using ovftool, keep getting error.


we are trying to get the Cisco ISE OVA deployed in the virtual center.

The Cisco guides mentioned that due to some incompatibility with the 6.5 version this should be done using the ovftool.exe utility.

Now this is how I am trying the command:

.\ovftool.exe -ds="nfs-datastore-01" "C:\OS Devices\Cisco ISE\ISE-" vi:"// Use Cluster/"

The hierarchy is:

Data Center Name = DataCenter

Cluster Name = General Use Cluster

Host IP =


I had the "#" in my password and I have removed that now. It still does not work.

I get an error saying: Error: Locator does not refer to an object:

What do you folks suggest?

My username contains and "@" and the password contains an "!", just as an FYI.



0 Kudos
2 Replies
Hot Shot
Hot Shot

The error seems to indicate a problem with the vCenter path.  Have you tried backing up to the root of vCenter and working your way down?  It will throw an error, but will give you a list of possible completions for the next object in the path.  For example, try:

.\ovftool.exe -ds="nfs-datastore-01" "C:\OS Devices\Cisco ISE\ISE-" vi:"//"

This should give you a list with "DataCenter" as one of the options.  Add that to the path and work your way down.

You could also try using a query for the destination host:

.\ovftool.exe -ds="nfs-datastore-01" "C:\OS Devices\Cisco ISE\ISE-" vi:"//"


Im having the same exact issue.  Same error.  I try using vi location with just the IP, and it gives me hints on the DC and vm/template folers to use, but when I start trying to use them, chasing them all down and trying every option it gives, they all fail with the same Error: Locator does not refer to an object:

0 Kudos