VMware Cloud Community

hardware status error hardware monitoring service on this host is not responding or not available

Hi ,

we have this error in vcenter with hardware status in esxi in  version 4.1 , ww have  enviroment vcenter 5.5 u2 ,

Only problem in esxi version 4.1 and all esxi 4.1 are in DMZ , and work ok in 5.5 esxi hosts

Error in log vws.log .:

[2015-02-18 08:07:08,508 pool-30-thread-2  ERROR com.vmware.vim.cimmonitor.service.impl.CimMonitorImpl] CertificateException in thumbprint computing: msg: certificate bytes returned from VC is null,


java.security.cert.CertificateException: certificate bytes returned from VC is null

  at com.vmware.vim.cimmonitor.service.impl.CimMonitorImpl.getHostCertThumbprint(CimMonitorImpl.java:588)

  at com.vmware.vim.cimmonitor.service.impl.CimMonitorImpl.createCimClient(CimMonitorImpl.java:726)

  at com.vmware.vim.cimmonitor.service.impl.CimMonitorImpl.createCimClient(CimMonitorImpl.java:874)

  at com.vmware.vim.cimmonitor.service.impl.HostRefresherTask.refreshHostInt(HostRefresherTask.java:205)

  at com.vmware.vim.cimmonitor.service.impl.HostRefresherTask.run(HostRefresherTask.java:118)

  at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)

  at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)

  at java.lang.Thread.run(Unknown Source)

[2015-02-18 08:07:08,515 pool-30-thread-2  WARN  com.vmware.vim.cimmonitor.util.ThumbprintTrustManager] Invalid SSL thumbprint. Expected: ,received: E0:D5:C5:63:E0:C5:5D:6A:8D:26:D4:D4:F7:80:5E:6D:FC:51:2E:98

[2015-02-18 08:07:08,515 pool-30-thread-2  WARN  com.vmware.vim.cimmonitor.service.impl.CimMonitorImpl] Couldn't contact CIMOM on esx99.domain.com/host-33928

We tried remove host and add again in vcenter , not problem in dns resolucion , open port 5989 in firewall . We are lost.

some idea ?

thanks very much

0 Kudos
2 Replies

Did you find a solution to this? 

I get the same error after installing vCenter 5.0 Update 3e when trying to view the Hardware Status Tab of my ESXi 4.x Hosts.  It was working before I installed Update 3e.

0 Kudos

Got the same problem after upgrading to vcenter 5.5U3, it was fine with 5.5U1. I don't want to remove and re-add the host as it will take too much reconfiguration. Newly added host appears fine,only the old one got the problem.


[2016-03-10 14:51:26,525 pool-30-thread-8  WARN  com.vmware.vim.cimmonitor.util.ThumbprintTrustManager] Invalid SSL thumbprint. Expected: ,received: 67:F2:59:D6:4F:52:AB:7E:E7:74:17:2B:44:68:FD:51:04:96:E8:F0

How can I solve the invalid SSL cert problem?

0 Kudos