VMware Cloud Community
tedztar
Contributor
Contributor

Vcenter not installing on New old hosts

Hi, I have been trying to get some old hosts operating on VMware however every time I try to install VCenter on a VM it fails with an unexpected error.

Any ideas, I have attached the logs for reference.

Reply
0 Kudos
7 Replies
sraghavendrar
VMware Employee
VMware Employee

Hi,

What version of VC are you trying to install? Which is the windows server on which you are trying to install vcenter?

-Supreeth

Tags (1)
Reply
0 Kudos
tedztar
Contributor
Contributor

V6.5 U3 (Latest cant think the letter off my head)

and installed on windows server 2019

We are also running ESXI 5.5 as thats the latest that is compatible with the old hosts.

Reply
0 Kudos
sraghavendrar
VMware Employee
VMware Employee

Hi,

Can you check the supported host operating system for vcenter server 6.5 U3?

According to KB https://kb.vmware.com/s/article/2091273 , Windows server 2019 is not listed as a supported operating system.

Regards,

Supreeth

Reply
0 Kudos
BoPesala
Enthusiast
Enthusiast

This can happen if there is a previous version of vcenter not properly decommissioned. Check if you have a running vcenter appliance. 

Tags (1)
Reply
0 Kudos
tedztar
Contributor
Contributor

We wiped the servers completly before doing anything.

All I have on the hosts is The Vcenter server and a DC right now

Might go for the appliance instead

Reply
0 Kudos
nachogonzalez
Commander
Commander

Why install it on windows and not on a VCSA directly.
on Version 6.7 Windows is already deprecated.

Reply
0 Kudos
Ajay1988
Expert
Expert

Its mostly a permissions issue with the account used to install.  Better to use a VCSA to avoid all this unwanted issues. Also windows is deprecated now

 

2021-05-09T23:32:48.270Z Failed to determine if firewall service is running. Details: (5, 'OpenService', 'Access is denied.')
2021-05-09T23:32:48.270Z ['Traceback (most recent call last):\n', ' File "C:\\Program Files\\VMware\\vCenter Server\\firstboot\\visl-support-firstboot.py", line 676, in <module>\n Main()\n', ' File "C:\\Program Files\\VMware\\vCenter Server\\firstboot\\visl-support-firstboot.py", line 665, in Main\n DoFirstboot()\n', ' File "C:\\Program Files\\VMware\\vCenter Server\\firstboot\\visl-support-firstboot.py", line 515, in DoFirstboot\n genPortInstallParams()\n', ' File "C:\\Program Files\\VMware\\vCenter Server\\firstboot\\visl-support-firstboot.py", line 306, in genPortInstallParams\n portsToOpenMap = openFirewallPorts(installParams);\n', ' File "C:\\Program Files\\VMware\\vCenter Server\\firstboot\\visl-support-firstboot.py", line 163, in openFirewallPorts\n if not isFirewallSvcRunning():\n', ' File "C:\\Program Files\\VMware\\vCenter Server\\python-modules\\cis\\utils.py", line 1750, in isFirewallSvcRunning\n fwSvcControl.open()\n', ' File "C:\\Program Files\\VMware\\vCenter Server\\python-modules\\cis\\utils.py", line 1301, in open\n win32service.SERVICE_ALL_ACCESS)\n', "error: (5, 'OpenService', 'Access is denied.')\n"]

If you think your queries have been answered
Mark this response as "Correct" or "Helpful".

Regards,
AJ
Reply
0 Kudos