thiag2011
Enthusiast
Enthusiast

Vcenter Search is not working

Hi all,

When I tried to search an object( be it a vm/host/datastore) from vcenter search feature available at top right of the vcenter, it throws the below error

"Login to the query service failed.The server could not interpret the communication from teh client.(The remote server returned an error: (503) Server Unavailable.)"

But when I point to a specific host or cluster  and search its object, it works.

I browsed net to find suggestions as reinstall vcenter.

Instead pl. let me know the cause for this issue and the way to fix the same.

0 Kudos
4 Replies
ExpletiveDelete
Enthusiast
Enthusiast

try setting the inventory service to logon as a domain account and then restarting the service

0 Kudos
thiag2011
Enthusiast
Enthusiast

Thanks for your reply.

The same setting( logon as a local account) works in one of my other vcenter.

So I believe setting logon as domain account will not solve the problem.

0 Kudos
admin
Immortal
Immortal

Check If IS is working and VC is registered with IS. Also look into IS logs and see if there is any error.

Thanks,

DJ

0 Kudos

If the issue is with Appliance

http://kb.vmware.com/selfservice/microsites/search.do?language=en_US&cmd=displayKC&externalId=206302...

For normal vCenter server

VMware KB: Search fails and Hardware Health and Health Status plug-ins are disabled in the vSphere C...

------------------------------------------------------------------------- Follow me @ www.vmwareguruz.com Please consider marking this answer "correct" or "helpful" if you found it useful T. Sateesh VCIX-NV, VCAP 5-DCA/DCD,VCP 6-NV,VCP 5 DCV/Cloud/DT, ZCP IBM India Pvt. Ltd
0 Kudos