POFIT
Enthusiast
Enthusiast

VCenter 6.5 Installation Failed

Dear All,

I have tried many times to install VMWare vCenter 6.5 but still no luck. I have tried different vcenter 6.5 version and esxi 6.5 version. DNS is working perfectly fine no issue. I have tried vCenter (VMware-VCSA-all-6.5.0-4944578) on Esxi 6.5 (VMware-VMvisor-Installer-201701001-4887370.x86_64 ) same error. I have also tried vCenter ((VMware-VCSA-all-6.5.0-4944578) on Esxi (VMware-VMvisor-Installer-6.5.0.update01-5969303.x86_64). The installation stuck on 80% installing RPM. Please also find attached the VCA VM snaptshot which shows the error.  Please also find attached the log file error for more details.
The strange thing is, two months back i have successfully install the same version on another server with same specs and model but now on this server could not success. Hardware is HP ProLiant BL460c G7.
7 Replies
vijayrana968
Virtuoso
Virtuoso

Check in /var/log/vmware/upgrade/requirements-upgrade-runner.log if any pre-requisite missing.

0 Kudos
daphnissov
Immortal
Immortal

Can you post screenshots of your installation parameters? Also ensure that the workstation from which you're running the installer has its time in sync with the ESXi host on which the appliance is deployed. All time must be synched or else failures result.

POFIT
Enthusiast
Enthusiast

Dear,

Please find attached the settings which i am going to used for installing vcenter.

0 Kudos
PGinhoux
Enthusiast
Enthusiast

Hi,

I have myself a failure to install vCSA.

It is due to the credentials supplied ed in the vCSA build that has expired at the time of the installation;

Do you find the installer log file located (for me) in the "\Users\CMMAdmin\AppData\Local\Temp\12\vcsaUiInstaller" folder. If so, my log reports these errors :

Failed to get fileTransferInfo:ServerFaultCode: Failed to authenticate with the guest operating system using the supplied credentials.

According the VMware support team, it is fixed with the new build : 6.5U1c build 7119157.

If this is your problem, try this build on your side and keep me posted.

For your info, it still fails with the same error, so that I have just opej a ticket to VMware.

I hope this help.

Regards

Patrick

0 Kudos
daphnissov
Immortal
Immortal

As suggested, get the latest 6.5 U1c ISO that has the fix for the expiring root password issue. Second, once you try your installation again, make sure the ESXi host to which you are deploying this and the workstation from which you're launching the installer have their times in sync.

msripada
Virtuoso
Virtuoso

Agreed !

VMware vCenter Server 6.5 Update 1c Release Notes

vCenter Server Appliance Deployment Issues

An expired root password might fail some upgrade, install and migrate operations for VMware vCenter Server Appliance

You might fail to deploy vCenter Server Appliance (VCSA) because VMware Photon OS does not allow you to replace an expired root password. This issue might affect installation of vCenter Server Appliance with vCenter Server Appliance 6.5 and vCenter Server Appliance 6.5.0a builds, as well as file-based restore from backups, migration from vCenter Server for Windows to VCSA, and upgrade from older version to vCenter Server Appliance 6.5, if you use these builds.

This issue is resolved in this release.

0 Kudos
PGinhoux
Enthusiast
Enthusiast

Hi All,

In my last message (27 nov. 2017 14:42), I said that my vCSA installation still fails even with the latest package that fixes the root password issue.

It thought that it failed at about 80% because the Installer log file contains errors on the credentials during about 7 minutes. Example:

2017-12-01T13:15:28.117Z -
debug: initiateFileTransferFromGuest error: ServerFaultCode: Failed to
authenticate with the guest operating system using the supplied credentials.

2017-12-01T13:15:28.119Z -
debug: Failed to get fileTransferInfo:ServerFaultCode: Failed to authenticate
with the guest operating system using the supplied credentials.

2017-12-01T13:15:28.120Z - debug: Failed to get url of file in guest vm:ServerFaultCode: Failed to authenticate with the guest operating system using the supplied credentials.

2017-12-01T13:15:28.120Z -
debug: [1]pollRpmInstallProgress:getGuestFileErr:ServerFaultCode: Failed to
authenticate with the guest operating system using the supplied credentials.

2017-12-01T13:22:18.564Z -
debug: initiateFileTransferFromGuest error: ServerFaultCode: Failed to
authenticate with the guest operating system using the supplied credentials.

2017-12-01T13:22:18.566Z -
debug: Failed to get fileTransferInfo:ServerFaultCode: Failed to authenticate
with the guest operating system using the supplied credentials.

2017-12-01T13:22:18.567Z -
debug: Failed to get url of file in guest vm:ServerFaultCode: Failed to
authenticate with the guest operating system using the supplied credentials.

2017-12-01T13:22:18.567Z - debug: [42]pollRpmInstallProgress:getGuestFileErr:ServerFaultCode: Failed to authenticate with the guest operating system using the supplied credentials.

So that I reported the problem to VMware support (ticket 17636589811) and in the meantime, I try again the installation that eventually was completed (Step 1 and then 2).

Working with VMware, there 'credentials' errors can be ignored. It Seems to be these login attempts are too early while the appliance is still going though first boot initialization. Password for root user is yet be changed, but the installation process is trying to login with password supplied during the installation.  The future update would removed these errors.

I hope this help.

0 Kudos