VMware Cloud Community

VCenter 5.1 is not starting after doing a SQL DB move from one server to another.

After doing a backup and restore of the VCenter 5.1 SQL DB in to a different server. I have tried the following with no success

1. I have reconfigured the HOSTS file and successfully ping localhost

2. I have rebuilt the web.xml file with no success

3. I have checked the registry settings in the virtual center server for the DSN name consistency but I didn't see the DB in the registry key for the 64 bit. I only found it in the 32 bit location. Is this mean I have a 32 bit ODBC? I thaught a 64 bit ODBC was needed for Virtual Center server, I ahve to go back to my documentation and see why the discrepancy.

I have checked with our DB team and they concluded that nothing changed from the old DB location to the new DB location. They said they did a backup in the old location then a restore on the new location, but for some reason they needed to modify some permissions in order to make other DBs work.

At this point I ran out of ideas and I have no visibility to he DB, also i asked them to check if the log files were full and they said they are not.

I'm getting the below errors every time I try to start the virtual center service. Any help will be greatly appreciated.

Windows could not start the VMware VirtualCenter Server on Local Computer. For more information, review the System Event Log. If this is a non-Microsoft service, contact the service vendor, and refer to service-specific error code 2.

2014-05-07T13:24:44.099-07:00 [04020 error 'Default'] Found dangling SSL error: [0] error:00000001:lib(0):func(0):reason(1)

2014-05-07T13:24:44.099-07:00 [04020 error 'Default'] Found dangling SSL error: [1] error:00000001:lib(0):func(0):reason(1)

2014-05-07T13:24:44.099-07:00 [04020 error '[SSO][SsoFactory_CreateFacade]'] Unable to create SSO facade: vmodl.fault.SystemError.

2014-05-07T13:24:44.099-07:00 [04020 error 'vpxdvpxdMain'] [Vpxd::ServerApp::Init] Init failed: Vpx::Common::Sso::SsoFactory_CreateFacade(sslContext, ssoFacadeConstPtr)

--> Backtrace:

--> backtrace[00] rip 000000018018aafa

--> backtrace[01] rip 0000000180102568

--> backtrace[02] rip 00000001801038de

--> backtrace[03] rip 000000018008d24b

--> backtrace[04] rip 00000000003b5c2c

--> backtrace[05] rip 00000000003d6512

--> backtrace[06] rip 00000001406815c1

--> backtrace[07] rip 000000014067b3dc

--> backtrace[08] rip 000000014089cbdb

--> backtrace[09] rip 000007fefd43a82d

--> backtrace[10] rip 0000000076f759ed

--> backtrace[11] rip 00000000771ac541


2014-05-07T13:24:44.099-07:00 [04020 warning 'VpxProfiler'] ServerApp::Init [TotalTime] took 3282 ms

2014-05-07T13:24:44.099-07:00 [04020 error 'Default'] Failed to intialize VMware VirtualCenter. Shutting down...

2014-05-07T13:24:44.099-07:00 [04020 info 'vpxdvpxdSupportManager'] Wrote uptime information

2014-05-07T13:24:52.818-07:00 [00948 warning 'VpxProfiler' opID=SWI-269e2dcd] VpxUtil_InvokeWithOpId [TotalTime] took 12000 ms

2014-05-07T13:25:04.818-07:00 [00948 warning 'VpxProfiler' opID=SWI-fed9183d] VpxUtil_InvokeWithOpId [TotalTime] took 12000 ms

2014-05-07T13:25:16.819-07:00 [00948 warning 'VpxProfiler' opID=SWI-9e1bfa80] VpxUtil_InvokeWithOpId [TotalTime] took 12000 ms

2014-05-07T13:25:28.819-07:00 [00948 warning 'VpxProfiler' opID=SWI-40e63a63] VpxUtil_InvokeWithOpId [TotalTime] took 12000 ms

2014-05-07T13:25:40.820-07:00 [00948 warning 'VpxProfiler' opID=SWI-c03c5f42] VpxUtil_InvokeWithOpId [TotalTime] took 12000 ms

2014-05-07T13:25:40.913-07:00 [04020 info 'Default'] Forcing shutdown of VMware VirtualCenter now

0 Kudos
2 Replies


check this vmware's kb, maybe it helps:

VMware KB: VirtualCenter Server service fails to start with the error: Unable to create SSO facade: ...

Perhaps checking this other kb is a good idea too:

VMware KB: Migrating vCenter Server to a different host machine

VMware KB: Moving the VMware vCenter Server 4.x/5.x SQL database

Best regards,


------------------------------------------------------------------------------------------------- PLEASE CONSIDER AWARDING any HELPFUL or CORRECT reply. Thanks!! Por favor CONSIDERA PREMIAR cualquier respuesta ÚTIL o CORRECTA . ¡¡Muchas gracias!! VCP3, VCP4, VCP5-DCV (VCP550), vExpert 2010, 2014 BLOG: http://communities.vmware.com/blogs/VirtuallyAnITNoob
0 Kudos
VMware Employee
VMware Employee


Can you try the solution from below VMware KB article.

http://kb.vmware.com/kb/2062622 - Virtual Center Server fails to start due to virus scan with the error: Vpx::Common::Sso::SsoFactory_CreateFacade(sslContext, ssoFacadeConstPtr)

0 Kudos