Raudi
Expert
Expert

VCSA patch hangs in Web Management

Hi,

since a few patches ago something hangs in the Web GUI of the VCSA 7.0.2, directly after login i got:

Raudi_0-1629832410592.png

And everything i'm trying to select i can't cancel that dialogs. The only way is to modify the URL in the browser to get the normal GUI. But next time login the dialog comes again.

I need a way to reset the installation status for the Web GUI.

Today i updated from 7.0.2.00200 to 7.0.2.00400 without anny issues via CLI, but this message in the Web GUI is still there.

What can i do?

Kind regards
Stefan

0 Kudos
7 Replies

Hi Raudi, did you try with other browser and cleaning cookies and stuf from the current?

If succedded seing this error might be related to that.

-------------------------------------------------------------------
Triple VCIX (CMA-NV-DCV) | vExpert | MCSE | CCNA
0 Kudos
Raudi
Expert
Expert

No, must be something in the VCSA, even when i login from a different workstation i get the error message.

And this are never ending messages:

1. Installation failed -> Can only push continue.

2. Result of the pre-installation check: Update 7.0.2.00200 is not found -> Can push cancel or retry.

3. With retry i get the error from 2.

4. With cancel i got the error from 1 and we are starting again from point 1.

 

0 Kudos

Hi Raudi,

Can you export the logs and try to find the lines above the error you mentioned to try to undestand 

(here how to: https://docs.vmware.com/en/VMware-vSphere/7.0/com.vmware.vcenter.upgrade.doc/GUID-6DB20E68-CE77-426E...)

 

Also, I would recommend to open a support ticket for the same (if this vcenter is relevant to your platform)

-------------------------------------------------------------------
Triple VCIX (CMA-NV-DCV) | vExpert | MCSE | CCNA
0 Kudos
Raudi
Expert
Expert

I will search the logs...

And this isn't the first time that i see this problem, so i had the hope someone knows what to do. Must be a config file with some wrong content inside about the state of the installation.

A case will be the really last option, but i think before i open a case i will reinstall the vcenter, beause we are enterprise partner and this is my test environment, for this we have only 5 cases in one year for free, i don't want to waste that for this...

But at the other side i want to know how to fix this....

0 Kudos
Raudi
Expert
Expert

In the /var/log/vmware/applmgmt/applmgmt.log i found this:

Spoiler
2021-09-06T15:24:40.176 [3699]DEBUG:vmware.appliance.update.update_state:In State._get using state file /etc/applmgmt/appliance/software_update_state.conf
2021-09-06T15:24:40.177 [3699]INFO:vmware.appliance.update.update_state:Found operation in progress /storage/core/software-update/stage_install_operation
2021-09-06T15:24:40.177 [3699]DEBUG:vmware.appliance.update.update_state:Operation in progress is finished
2021-09-06T15:24:40.177 [3699]DEBUG:vmware.vherd.transport.vapi:State 'INSTALL_FAILED'
2021-09-06T15:24:40.177 [3699]DEBUG:vmware.vherd.transport.vapi:Only ['INSTALL_IN_PROGRESS'] block []
2021-09-06T15:24:40.181 [3699]DEBUG:vmware.appliance.update.update_state:In State._get using state file /etc/applmgmt/appliance/software_update_state.conf
2021-09-06T15:24:40.181 [3699]INFO:vmware.appliance.update.update_state:Found operation in progress /storage/core/software-update/stage_install_operation
2021-09-06T15:24:40.181 [3699]DEBUG:vmware.appliance.update.update_state:Operation in progress is finished
2021-09-06T15:24:40.181 [3699]DEBUG:vmware.vherd.transport.vapi:State 'INSTALL_FAILED'
2021-09-06T15:24:40.181 [3699]DEBUG:vmware.vherd.transport.vapi:Only ['INSTALL_IN_PROGRESS'] block []
2021-09-06T15:24:40.185 [3699]DEBUG:vmware.appliance.update.update_state:In State._get using state file /etc/applmgmt/appliance/software_update_state.conf
2021-09-06T15:24:40.185 [3699]INFO:vmware.appliance.update.update_state:Found operation in progress /storage/core/software-update/stage_install_operation
2021-09-06T15:24:40.185 [3699]DEBUG:vmware.appliance.update.update_state:Operation in progress is finished
2021-09-06T15:24:40.186 [3699]DEBUG:vmware.vherd.transport.vapi:State 'INSTALL_FAILED'
2021-09-06T15:24:40.186 [3699]DEBUG:vmware.vherd.transport.vapi:Only ['INSTALL_IN_PROGRESS'] block []

I have now renamed this file:

mv /etc/applmgmt/appliance/software_update_state.conf /etc/applmgmt/appliance/software_update_state.conf.bak

This was the content:

"state": "INSTALL_FAILED",
"version": "7.0.2.00200",
"latest_query_time": "2021-05-26T05:39:27Z",
"operation_id": "/storage/core/software-update/stage_install_operation"

and after renaming, the file was recreated with this content:

"state": "UP_TO_DATE"

Currently i see no errors in the applmgmt.log regarding this and the GUI looks fine. We will see when the next update is available...

Raudi
Expert
Expert

A new patch is available, but i can't stage via GUI. I get this error:

Raudi_0-1632233595376.png

But via CLI no problems:

Command> software-packages stage --url --acceptEulas
[2021-09-21T16:10:47.264] : UpdateInfo: Using product version 7.0.2.00400 and build 18356314
[2021-09-21T16:10:47.264] : Target VCSA version = 7.0.2.00500
[2021-09-21 16:10:48,010] : Running requirements script.....
[2021-09-21T16:10:58.264] : Evaluating packages to stage...
[2021-09-21T16:10:58.264] : Verifying staging area
[2021-09-21T16:10:58.264] : Staging process completed successfully

Why is there such a difference between the GUI and CLI?

0 Kudos
Raudi
Expert
Expert

O.k. now the version 7.0 U3 is available and i found this:

 

Stage Only & Stage and Install buttons disabled when updating to vSphere 7.0 Update 2a (williamlam.c...

 

It is a different problem, but i used this commands to cleanup.

 

After this i was able to update my VCSA in the Web GUI.

0 Kudos