sreeve3939
Enthusiast
Enthusiast

VCSA 6.7 install wizard insists on DNS server

Jump to solution

Installed VCSA many times with little/no problems.

Now attempting it in an isolated network with no DNS server.

After a lot of searching/googling: tried a dummy IP, a real IP that didn't have DNS, etc.

Same error every time.

Why does the VCSA install require a DNS server?

I could create a DNS server on linux in the environment, but have no idea what records to put in.

Any workaround?  /etc/hosts entries perhaps - either in the vcsa or on the dns server?

1 Solution

Accepted Solutions
nirmalgnair
VMware Employee
VMware Employee

Hi @sreeve3939

VCSA deployment needs DNS resolution as a pre-requisite but you can try the following.

VCSA_IP.jpg

Here I have used DNS as the Gateway IP itself. Once the Stage 1 is completed. Open the VCSA console and enable SSH using the below command.

systemctl restart sshd

Once SSH is enabled, take SSH to the newly deployed appliance and edit the hosts file

vi /etc/hosts

Edit the host file to look like

# Begin /etc/hosts (network card version)
# VAMI_EDIT_BEGIN
127.0.0.1   localhost.localdomain
127.0.0.1       localhost
127.0.0.1       photon-machine
# VAMI_EDIT_END
# End /etc/hosts (network card version)

Save the file.

Also you can go ahead and remove the default gateway information from resolv.conf (vi /etc/resolv.conf)

Save the file and continue with the Stage2.

View solution in original post

0 Kudos
17 Replies
sreeve3939
Enthusiast
Enthusiast

This is a good explanation of what I did.

I did all the same steps:

https://www.kieri.com/how-to-install-vcenter-6-7-and-6-0-and-6-5-with-no-dns-only-ip-address/

0 Kudos
AhmedIbrahimVMw
Enthusiast
Enthusiast

vCenter Server installation requires a DNS server, it is mentioned in the official documentation:

DNS Requirements for the vCenter Server Appliance and Platform Services Controller Appliance

If you would like to install vCenter Server using the IP address as the system name, then you have to populate the DNS IP address field with any IP address, and hopefully this would "fool" the wizard and allow you to proceed to the next step.

0 Kudos
RickVerstegen
Expert
Expert

Did you leave “Host Network DNS Servers” empty? Also do not add anything in  “Domain Name” and “Domain Search Path”.

Add the server IP address as “Host Network Identity”.

Although I do not recommend to install VCSA without proper DNS.

Blog: https://rickverstegen84.wordpress.com/ Twitter: https://twitter.com/verstegenrick
0 Kudos
berndweyand
Expert
Expert

William Lam also stated that it is possible to deploy vcsa w/o dns - it is not supported but works:

https://www.virtuallyghetto.com/2018/12/is-a-dns-server-still-required-when-using-a-static-ip-for-vc...

0 Kudos
sreeve3939
Enthusiast
Enthusiast

Tried William Lam's page also - same results.

Tried to install a BIND server on a linux box using webmin:

https://www.serverpronto.com/kb/page.php?id=setting+up+dns+using+webmin

and BIND is up and running.  But I have no idea what records need to be put in to satisfy the vcsa install.

perahps vcsa install just needs ANY dns server - regardless of what's provisioned on the dns server.

0 Kudos
berndweyand
Expert
Expert

what values did you put in for fqdn, ip, default-gw and dns-server?

0 Kudos
sreeve3939
Enthusiast
Enthusiast

pastedImage_1.png

0 Kudos
berndweyand
Expert
Expert

ok - and 172.22.1.1 is reachable all the time during deployment ?

0 Kudos
sreeve3939
Enthusiast
Enthusiast

Testing the management network from the esxi console shows that esxi has no issues at all with 172.22.1.1.

Therefore, I have no reason to believe that the vcsa install would have any issues contacting 172.2.1.1 during the install.

pastedImage_0.png

The PC which mounts the ISO and performs the install to esxi also has no issues contacting that IP: (install error message included for good measure):

pastedImage_1.png

0 Kudos
daphnissov
Immortal
Immortal

But I have no idea what records need to be put in to satisfy the vcsa install.

You need an A record for forward resolution and a PTR record for reverse resolution. The vCSA will attempt to look itself up in the local DNS server you provide and query for these records to ensure the IP you've provided is found. If you've done this and it's still not working, you either have DNS issues or network issues. As stated, you really need to use DNS as this is considered core, critical infrastructure without which just about anything won't work properly.

0 Kudos
berndweyand
Expert
Expert

will try that tomorrow

0 Kudos
berndweyand
Expert
Expert

tried to deploy in that way - same error 😞

0 Kudos
nirmalgnair
VMware Employee
VMware Employee

Hi @sreeve3939

VCSA deployment needs DNS resolution as a pre-requisite but you can try the following.

VCSA_IP.jpg

Here I have used DNS as the Gateway IP itself. Once the Stage 1 is completed. Open the VCSA console and enable SSH using the below command.

systemctl restart sshd

Once SSH is enabled, take SSH to the newly deployed appliance and edit the hosts file

vi /etc/hosts

Edit the host file to look like

# Begin /etc/hosts (network card version)
# VAMI_EDIT_BEGIN
127.0.0.1   localhost.localdomain
127.0.0.1       localhost
127.0.0.1       photon-machine
# VAMI_EDIT_END
# End /etc/hosts (network card version)

Save the file.

Also you can go ahead and remove the default gateway information from resolv.conf (vi /etc/resolv.conf)

Save the file and continue with the Stage2.

View solution in original post

0 Kudos
sreeve3939
Enthusiast
Enthusiast

Thanks a lot for the idea.

I did what you said, and /etc/hosts seems already in that state, i.e. I didn't touch it:

pastedImage_0.png

I commented out the DNS server I put in the wizard.

Not sure what to do next.

Thanks.

0 Kudos
nirmalgnair
VMware Employee
VMware Employee

Kindly add the highlighted entries (hosts file) and continue with the Stage 2.

0 Kudos
sreeve3939
Enthusiast
Enthusiast

Thank you Nirmalgnair!  It worked.

nirmalgnair
VMware Employee
VMware Employee

Good to know that it worked 🙂

Have a good weekend.

Regards,

Nirmal Nair

vSphere Install-Upgrade Support

0 Kudos