mayurparmar777
Contributor
Contributor

VCSA 6.5 Backup failed

Hello Guys,

I am trying to backup the VCSA 6.5. but getting failed multiple times.

Giving error of BackupManager encountered an exception. Please check logs.

I have also checked logs but didn't understand the exact problem.

If anyone is facing same then help.

backup-error-1.jpg

backup-error.jpg

Thanks & Regards, Mayur Parmar, Blog: www.masteringvmware.com
0 Kudos
12 Replies
mhampto
VMware Employee
VMware Employee

What are the settings that are being used for the backup?  Also, what are the location settings for the destination of the backup?

0 Kudos
msripada
Virtuoso
Virtuoso

are you using https connection to iis?

How to natively backup vCSA to IIS using HTTPS

Request entity too large messages shows the same..

Thanks,

MS

0 Kudos
mayurparmar777
Contributor
Contributor

Hi,

I am taking backup using HTTPS.

In C drive.

Thanks & Regards, Mayur Parmar, Blog: www.masteringvmware.com
0 Kudos
mayurparmar777
Contributor
Contributor

msripada  yes I am using this method only but after 95% this error comes.

Thanks & Regards, Mayur Parmar, Blog: www.masteringvmware.com
0 Kudos
daphnissov
Immortal
Immortal

As requested by others, please post your full settings in use here. A screenshot would also help.

0 Kudos
mayurparmar777
Contributor
Contributor

Hi,

I am using an HTTPS Method for backup. I have set the location in system drive.
I have configured the IIS Server as provided in the below link:

How to natively backup vCSA to IIS using HTTPS

but after the 95% i am getting this error.

When i checked there are some of the files gets stored.

Thanks & Regards, Mayur Parmar, Blog: www.masteringvmware.com
0 Kudos
daphnissov
Immortal
Immortal

For the third time, please post your full settings and attach the log file showing failures.

0 Kudos
DaemonFF2
Contributor
Contributor

Hello!

I have same problem with VCSA backup to IIS/WebDAV (2012R2).

I tried to investigate the issue and I have found the root cause: HTTP RETURN CORE 413 from IIS. This result I can see in backup.log (on VCSA) and in web-server log on IIS.

Yes, I have read the article which is mentioned above (about configure WebDAV on IIS), but it is not my solution...

0 Kudos
DaemonFF2
Contributor
Contributor

Thank You for replay, but it does not help me.

I tried to increase the value of uploadReadAheadSize parameter up to 2G (in bytes, off course), then restart IIS, but issue does not come out.

0 Kudos
napagoda
Contributor
Contributor

Error "BackupManager encountered an exception. Please check logs for details." appeared while using SCP as the protocol.

0 Kudos
napagoda
Contributor
Contributor

Resolved the issue. I reffered the article in;

https://communities.vmware.com/t5/vCenter-Server-Discussions/vCenter-Server-Appliance-Backup-Process/td-p/2309987

SSH to the vcenter appliance and viewed the path /var/log/vmware/applmgmt/backup.log. Found below error in the log.

2021-11-01 05:03:37,018 [ConfigFilesBackup:PID-55106] INFO: tarCmd = tar -cz -C / --ignore-failed-read -T "/var/log/vmware/applmgmt/cfg_incl_w2lp_R.lst" -X "/var/log/vmware/applmgmt/cfg_excl_6hzWgF.lst" --warning="no-file-ignored"
2021-11-01 05:03:38,272 [ComponentScriptsBackup:PID-55109] ERROR: rc: 1, stderr: bash: /var/vcenterbkp/imagebuilder.gz: Permission denied

So I changed the folder permission of the backup location. Issue resolved.

 

 

0 Kudos