JudgementDay
Enthusiast
Enthusiast

VCHA setup failure

Jump to solution

Hi,

I have set my host configuration to split out the vswp files to a separate datastore for Virtual Machines.

When enabling VCHA I receive an error : 'VCHA cannot be enabled because disks are on more than one datastore'.

(I do not have an ISO or a snapshot against the VCSA which is the common cause for this error)

So via the VM overrides option I set the swap file location as 'Virtual Machine Directory' expecting all vswp files to move here on reboot.

After rebooting and re-trying VCHA I recieve the same error.

I have noticed there is two vswp files. One has moved to the Virtual Machine Directory but the other vmx-xxxxxxxx.vswp remains on the separate datastore.

Does anyone know where the location config for the vmx-xxxxxxxx.vswp is found so I can move its location to the Virtual Machine Directory?

Thanks for your help.

Tags (1)
0 Kudos
1 Solution

Accepted Solutions
a_p_
Leadership
Leadership

The only setting that I'm currently aware of, is a per VM setting "sched.swap.vmxSwapDir".

You may want to check whether this has been set for the VM, and remove it (or add it with the required value) to see if this helps.

André

View solution in original post

2 Replies
a_p_
Leadership
Leadership

The only setting that I'm currently aware of, is a per VM setting "sched.swap.vmxSwapDir".

You may want to check whether this has been set for the VM, and remove it (or add it with the required value) to see if this helps.

André

View solution in original post

JudgementDay
Enthusiast
Enthusiast

Thanks André.

Adding the setting to the vmx file worked.

0 Kudos