abhisheksha
Enthusiast
Enthusiast

Upgrading to ESXi 6.0 from 5.5. throws an error about VIB profiles

Jump to solution

Hi,


I am trying to update my ESXi from 5.5 to 6.0 using the esxcli but I receive the error -

/vmfs/volumes/4f0a37af-1ff59fa8-c5d8-001018a76a5a # esxcli software profile update -d /vmfs/volumes/4f0a37af-1ff59fa8-c5d8-

e-from-esxi6.0-6.0_update03.zip -p ESXi-6.0.0-20170202001-standard

[DependencyError]

VIB Cisco_bootbank_cisco-vem-v198-esx_5.2.1.3.1.5a.0-3.2.1 requires esx-base = 5.5.0, but the requirement cannot be satisfied within the ImageProfile.

I do recall installing the Nexus 1000v ages back, I think the configuration of this has remained. Can you please advise how best to resolve this?

Thanks!

Tags (1)
1 Solution

Accepted Solutions
vijayrana968
Virtuoso
Virtuoso

Can you check the loaded vem with command esxcli software vib list | grep cisco-vem

If you don't need it, remove it with loaded module name like esxcli software vib remove --vibname=cisco-vem-v144-esx and then retry update.

View solution in original post

4 Replies
vijayrana968
Virtuoso
Virtuoso

Seems your ESXI host have Cisco Nexus VEM installed, you can use the following tool for the procedure to follow and to ensure you are utilizing the correct upgrade path:

Nexus 1000V and ESX Upgrade Utility

Choose your initial and upgrade release levels and follow steps provided.

0 Kudos
abhisheksha
Enthusiast
Enthusiast

Hi,

I came across this answer on the Cisco Support Forum as well. Unfortunately, I am not upgrading N1Kv, I would like to remove this completely. There no VEMs present, and the ESXi is no longer joined to the same vCenter where the those plugins were installed. Please advise.

Thanks!

0 Kudos
vijayrana968
Virtuoso
Virtuoso

Can you check the loaded vem with command esxcli software vib list | grep cisco-vem

If you don't need it, remove it with loaded module name like esxcli software vib remove --vibname=cisco-vem-v144-esx and then retry update.

View solution in original post

abhisheksha
Enthusiast
Enthusiast

Thanks a lot! This worked and I was able to update!