sysadminunap
Contributor
Contributor

Unable to setup timezone for VCSA 6.5

Jump to solution

Hi everyone,

Troubleshooting an active directory VCSA integration I realize that the last one is 3 hours ahead because is set to UTC, but I'm unable to change the timezone to America/Santiago, although I click the edit button and select it, when saving timezone field keeps blank (no error displayed).

timezone-vcsa.PNG

NTP synchronization seems to be working correctly

ntpsync-vcsa.PNG

All 5 hosts administered by this VCSA are synchronize to the same NTP servers and get the correct time.

pastedImage_2.png

Running VCSA with embedded PSC version 6.5.0.10000 Build Number 5973321.

Please need advice on what to do to correct VCSA time cause I'm pretty sure this is the problem for syncing AD users (and a potential for a lot of other ones).

Thanks in advance.

Tags (2)
1 Solution

Accepted Solutions
theaaronstrong
Enthusiast
Enthusiast

Check out the release notes and search for Time Zone.

VMware vCenter Server 6.5 Update 1 Release Notes

Time Zone in the vCenter Server Appliance Management Interface (VAMI) is empty after you upgrade vCenter Server 6.0.x to vCenter Server 6.5.x

Time Zone in the VAMI is empty when you perform a minor upgrade in vCenter Server 6.0.x and major upgrade to vCenter Server 6.5.x.

Workaround:

  1. Log in to the appliance Bash shell of the vCenter Server Appliance.
  2. Run the following commands:

    cd /etc/
      rm -rf localtime
      ln -s /usr/share/zoneinfo/Etc/UTC /etc/localtime

After that check, the soft link should display the following information:

# ls -l /etc/localtime
lrwxrwxrwx 1 root root 23 Jun 21 17:12 /etc/localtime -> /usr/share/zoneinfo/UTC

View solution in original post

5 Replies
theaaronstrong
Enthusiast
Enthusiast

Check out the release notes and search for Time Zone.

VMware vCenter Server 6.5 Update 1 Release Notes

Time Zone in the vCenter Server Appliance Management Interface (VAMI) is empty after you upgrade vCenter Server 6.0.x to vCenter Server 6.5.x

Time Zone in the VAMI is empty when you perform a minor upgrade in vCenter Server 6.0.x and major upgrade to vCenter Server 6.5.x.

Workaround:

  1. Log in to the appliance Bash shell of the vCenter Server Appliance.
  2. Run the following commands:

    cd /etc/
      rm -rf localtime
      ln -s /usr/share/zoneinfo/Etc/UTC /etc/localtime

After that check, the soft link should display the following information:

# ls -l /etc/localtime
lrwxrwxrwx 1 root root 23 Jun 21 17:12 /etc/localtime -> /usr/share/zoneinfo/UTC

View solution in original post

sysadminunap
Contributor
Contributor

I failed to notice this issue detailed on release notes.  Now I was able to apply correct TimeZone.

timezone-vcsa2.PNG

Thanks very much theaaronstrong​ !

CoryIT
Enthusiast
Enthusiast

Thanks for bringing this to light.

I have had a case open with support for nearly a month, and they could not tell me what the issue was!

How do we action this in an HA setup?

Do we have to apply the change to all three nodes?

Cheers

James

0 Kudos
Tectight
Contributor
Contributor

Hi Everyone.

I can confirm this fix works as well.

0 Kudos
eliascastellano
Contributor
Contributor

Hello, I have the same detail with vcenter 6.5 but I have it installed in windows 2008 R2, as I can change there the option of UTC since I have 5 hours in my virtual machines

0 Kudos