Balaji201
Contributor
Contributor

Unable to see storage devices ?

Hi,

I am unable to see device list in vSphere console from existing ESXi server.

Got work around to run ’./service restart’ command in esxi server manually. Then only i can see all device. I need to do this every time when add disk from storage. Permanent fix from support is to upgrading vcenter to 6.5. Current environment is 6.0 update 2.

Is there any alternative solution available with power cli for my problem?

Can I execute ’./service restart’ from poercli without logging to ESX server ?

0 Kudos
4 Replies
a_p_
Leadership
Leadership

After presenting a new LUN from a storage system to an ESXi host, do a  rescan of the storage adapter. This can be done from the vSphere Client. This should detect the new LUN, and allow you to use it, and to e.g. create a new datastore on it.

André

0 Kudos
Balaji201
Contributor
Contributor

Hi A.P,

Thanks for the response. I did rescan of storage adapter but still same situation. One error in web gui that I am facing is "Error#1009". It is appearing when ever I click on ESXi->Configuration->Storage device.

Thanks

0 Kudos
MikeStoica
Expert
Expert

The 1009 error you get looks more like this VMware Knowledge Base .

How are your ESXi host connected to storage? FC/iSCSI/NFS?

0 Kudos
Beingnsxpaddy
Enthusiast
Enthusiast

How many hosts are in cluster?

Are you facing same issue on all hosts?

if yes, then can you confirm if the LUN id is consistent across the hosts.

Regards Pradhuman VCIX-NV, VCAP-NV, vExpert, VCP2X-DCVNV If my Answer resolved your query don't forget to mark it as "Correct Answer".
0 Kudos