henry_wang
Enthusiast
Enthusiast

Unable to apply DRS resource settings on host XXXX in Cluster1

ESXI version: 6.0 U2

VC Version:Version 6.0.0 Build 6855238

one of ESXI host always display this erroe, unable to apply DRS Resource settint , DRS is disabled in cluster.

Event Details:

Description:Unable to apply DRS resource settings on host XXXX in Cluster1. The operation is not allowed in the current state.. This can significantly reduce the effectiveness of DRS.
Time:Oct 8, 2018 7:01:05 AM
Error Stack:

Failed to extend swap file from 0 KB to 33554432 KB.

Current swap file size is 0 KB.

Additional Event Details:
Type Name:DrsResourceConfigureFailedEvent
VC Build:7462484
Target Object Type:ClusterComputeResource
DataCenter Object Type:Datacenter
Host Object Type:HostSystem
Host Build:6921384
ChainId:7296025
Tags (3)
6 Replies
dbalcaraz
Expert
Expert

Hello Henry,

It's an strange behaviour as the ESXi host doesn't have a swap file.

Anyway, could you check if you have enough space in the ESXi's local datastore?

Also, I would check the .vxpd log in order to see what it's bothering DRS even is disabled.

If there are no hints, I would suggest to Remove the host from the cluster and then adding it again.

-------------------------------------------------------- "I greet each challenge with expectation"
0 Kudos
Ikester11
Contributor
Contributor

That error can be safely ignored.  To clear it, restart the ESXi management agents:

SSH into the ESXi host and type: services.sh restart

GayathriS
Expert
Expert

Put the host in maintenance mode and, you guessed it, restart the management services. Once the ESX host reconnected, the error and the red exclamation disappeared. This is yet another case where there was a disconnect between the ESX hosts and vCenter Server instance.

Reference link:

https://sflanders.net/2010/04/15/unable-to-apply-drs-resource-settings-on-host/

Please consider marking this answer as correct and helpful if this helps you.

regards

Gayathri

0 Kudos
Srinivasu13
Enthusiast
Enthusiast

check scratch partion.

Remove the scratch partion path and reboot the host.

------------------------------------------------------------------------------- If you found this or any other answer helpful, please consider to award points. (use Correct or Helpful buttons) Regards, Srini
0 Kudos
rcmills02
Contributor
Contributor

This post is a little old, but for the sake of anyone else running across this post, I thought I'd share what fixed this for me.

I recently had this same issue:

DRS resource settings could not be successfully applied to a host in the cluster....

I found the time setting on this host was out of sync with other hosts in the same cluster.  For some reason, the host showing the error message was about 5 hours ahead of the other hosts in the cluster.

I manually set the time to match the other hosts, refreshed vSphere Web Client and the Error message cleared immediately..  I will go back in to confirm NTP is working.

This could be a different issue for you, but it's worth a look.

0 Kudos
Stanley_
Enthusiast
Enthusiast

0 Kudos