Time sync issues between VCSA & PSC

Running 2 VCSA 6.5 with an external platform controller and ESXi 6.5. The ESXi hosts are pointed at a NTP server as well as the 2 VCSA's and PSC. One of the VCSA is not showing the correct time while the hosts and 2 other appliances are. I can connect to the one vCenter, just not the other.

I have tried the following:

Rebooted the VCSA and PSC.

Stop/Start/Restart the NTPD service on the VCSA.

Tried registering the VM on another ESXi host, but then I lose network connectivity. Using a distributed switch, so I am guessing this is why I am losing the network connectivity.

Changed the VCSA to get its time from the host.

Everything that I have tried has not help and I have run out of any other ideas, so seeing if anyone else can provide further assistance.

0 Kudos
1 Reply


Consider this point you don't have Timezone on ESXi host but there is timezone setting on VC/PSC appliance. So maybe you set both of them (ESXi / vCenter) to same NTP Server but there is different time set. And also remember if you set NTP for ESXi from SSH/Shell you may see different time whenever you connect with vSphere client/ Web Client. So if you want to set same time for ESXi and vCenter Servers to do management task for example checking logs and UDP 902 (VPXA needs to have same time)

consider timezone of vCenter and PSC servers beside NTP configuration

Please mark my comment as the Correct Answer if this solution resolved your problem
0 Kudos