YIPKC
Enthusiast
Enthusiast

This is a vSphere Web Client (Flash) only plugin indicated by the missing type="html" plugin manifest attribute.

Jump to solution

Hi ,

the error show after I upgrade my vCenter from 6.7u1 to 6.7u2

Who know what's the problem?

Tags (1)
1 Solution

Accepted Solutions
_vladi_
VMware Employee
VMware Employee

Hi all,

Ray is correct.

There is a new vSphere Client (HTML) feature in 6.7U2 that displays plugin deployment status messages for the HTML Client. This is done via vCenter tasks and those tasks are also visible inside the vSphere Web Client (Flash) which causes the confusion.

Please ignore these error messages within the Flash Client.

I will take it up with priority to resolve this in a follow up release.

Thank you for the feedback.

Cheers,

Vladi

View solution in original post

0 Kudos
20 Replies
asajm
Expert
Expert

Hi YIPKC

Please share the log file for more details

If you think your queries have been answered
Marking this response as "Solution " or "Kudo"
ASAJM
0 Kudos
YIPKC
Enthusiast
Enthusiast

May I know where and which log should  share?

Thanks

0 Kudos
asajm
Expert
Expert

Check

VMware Knowledge Base

or find /var/log/vmware/vpxd/vpxd.log

If you think your queries have been answered
Marking this response as "Solution " or "Kudo"
ASAJM
0 Kudos
wpskern
Enthusiast
Enthusiast

I got the same message after the upgrade. It has something to do with the imagebuilder or vcIntegrity? See attachments.

kurtd
Enthusiast
Enthusiast

Same issue after upgrading to 6.7u2.

0 Kudos
YIPKC
Enthusiast
Enthusiast

Hi asajm,

attached the log from vcenter.

It looks some information in the vsphere client log when I search "Flash" as the keywords.

but I don't know how to troubleshoot.

Thanks.

some example  in the log

[2019-04-27T12:24:31.766+08:00] [INFO ] ce-extension-mngr-pool-28719 70004507 100451 200015 com.vmware.vise.vim.extension.PluginStatusTaskManager             DEPLOYMENT_FAILED: Error deploying plugin package com.vmware.vcIntegrity.vcIntegrity:6.7.0.41703. Reason: Incompatible. This is a vSphere Web Client (Flash) only plugin indicated by the missing type="html" plugin manifest attribute.

[2019-04-27T12:24:31.779+08:00] [INFO ] ce-extension-mngr-pool-28718 70004507 100451 200015 com.vmware.vise.vim.extension.PluginStatusTaskManager             DEPLOYING: Deploying plugin package com.vmware.fallback.mixed:6.5.0 ...

[2019-04-27T12:24:31.779+08:00] [INFO ] plugin-validation1            com.vmware.vise.extensionfw.impl.OsgiUsageValidationService       Started validation of OSGi bad practices.

[2019-04-27T12:24:31.780+08:00] [INFO ] plugin-validation1            com.vmware.vise.extensionfw.impl.OsgiUsageValidationService       Finished validation of OSGi bad practices.

[2019-04-27T12:24:31.787+08:00] [INFO ] ce-extension-mngr-pool-28718 70004507 100451 200015 com.vmware.vise.vim.extension.PluginStatusTaskManager             DEPLOYMENT_FAILED: Error deploying plugin package com.vmware.fallback.mixed:6.5.0. Reason: Incompatible. This is a vSphere Web Client (Flash) only plugin indicated by the missing type="html" plugin manifest attribute.

[2019-04-27T12:24:31.788+08:00] [INFO ] plugin-validation1            com.vmware.vise.extensionfw.impl.OsgiUsageValidationService       Started validation of OSGi bad practices.

[2019-04-27T12:24:31.788+08:00] [INFO ] plugin-validation1            com.vmware.vise.extensionfw.impl.OsgiUsageValidationService       Finished validation of OSGi bad practices.

[2019-04-27T12:24:31.788+08:00] [INFO ] ncPluginDeploymentExecutor-1 70004507 100451 200015 c.vmware.vise.vim.extension.login.LoginPluginDeploymentInitiator  Check for new plugins completed in 1757 ms.

[2019-04-27T12:24:36.016+08:00] [WARN ] tp-nio-127.0.0.1-5090-exec-6 70004522 100451 200015 com.vmware.vise.mvc.tree.TreeNodeStateManagerImpl                 Failed to load user preferences.

0 Kudos
jezperks
Contributor
Contributor

Same issue after upgrading to 6.7 U2.

0 Kudos
TheBob1
Contributor
Contributor

Same on my Site!

0 Kudos
segersta
Contributor
Contributor

I did get the same issue after upgraded from U1 to U2 yesterday.

Hope someone will find the answer and solution for this issue.

0 Kudos
rayw613
Contributor
Contributor

client_plugin.png

Hi  all:

I think this is why the error messages happened . That is flash only plugin , when you login HTML5 web client , this plugin is incompatible.

I think we can ignore the error message.

Ray Wang

_vladi_
VMware Employee
VMware Employee

Hi all,

Ray is correct.

There is a new vSphere Client (HTML) feature in 6.7U2 that displays plugin deployment status messages for the HTML Client. This is done via vCenter tasks and those tasks are also visible inside the vSphere Web Client (Flash) which causes the confusion.

Please ignore these error messages within the Flash Client.

I will take it up with priority to resolve this in a follow up release.

Thank you for the feedback.

Cheers,

Vladi

0 Kudos
enpuna
Contributor
Contributor

Hi all,

In my case and after upgrade from VCSA 6.7U1 to VCSA 6.7U2 the HTML5 client does not start anymore.

I am using a VCSA 6.7U2 deployed from OVA, for lab testing, the previous VCSA 6.7U1 was working perfectly, however this new releas contains something that it was not fully upgraded.

Finally I solved the problem using a different browser, FIREFOX and CHROME, didn't work for me, just SAFARI was able to open a HTML session via VCSA.

Hope we can have a new patch release to solve this issue,

Thanks,

Regards,

0 Kudos
_vladi_
VMware Employee
VMware Employee

This sounds like a different issue.

Could you please clear your browser cache and see if this helps?

Cheers,

Vladi

0 Kudos
enpuna
Contributor
Contributor

Thanks vladi,

It works fine now, sometimes we forget the basic principles.

Regards,

TheBob1
Contributor
Contributor

On my Site, the problem still exists in Version 6.7.0 Build 13639324 (6.7U2a)

Why was the problem not fixed?

0 Kudos
_vladi_
VMware Employee
VMware Employee

This is not in the scope of any patch release (e.g. 6.7U2a).

A fix will be part of a future update release.

Cheers,

Vladi

0 Kudos
_vladi_
VMware Employee
VMware Employee

A new KB on this issue has been posted: VMware Knowledge Base

0 Kudos
_vladi_
VMware Employee
VMware Employee

The issue has been resolved in vSphere 6.7 U3 release.

There are more details in this blog post: https://pluginsblog.com/2019/08/21/vsphere-client-plugins-whats-new-in-6-7-u3/

Cheers,

Vladi

0 Kudos
Vinothkumar_G
Contributor
Contributor

Hi Vladimir, Thank you for sharing the article and details about the fix. I am facing the plugin error my vcenter (6.7.0 U3a, build=14792544), It is something I can ignore or an another version has fix to this issue?

0 Kudos