rebelfalls
VMware Employee
VMware Employee

RE: Issue with Linked Mode on vCenter

I have a situation where vCenter Link Mode is broken after inventory database reset. I have vCenter 6.7 & VxBlock System 740 w/ VMAX 200K

A bit of background, originally the '/dev/sda3' on Vplex Appliance was 100% out of space for my 'vcenter1' so I followed https://kb.vmware.com/s/article/2149278. 


The inventory service didn't start post reboot / DB truncate. So I downloaded the script from https://kb.vmware.com/s/article/2119422 and did a full reset of the inventory db on my vcenter1.
The i
nventory service still did not start after inventory service reset. I then did a password reset per https://kb.vmware.com/s/article/2146224
After this the inventory service started but the visibility of the Link Mode broke and logging in vc webclient for 'vcenter1' is only showing the 2 other VCs in my environment.

The inventory for 'vcenter1' is not visible from any web based connection. When connecting with fat client directly to 'vcenter1' the inventory is visible without any content from the 2 other VCs.

From https://kb.vmware.com/s/article/2113435 I see that key below is included the inventory DB and is responsible for showing the inventory of the linked VC.

com.vmware.cis.cls urn:cis.cls:

There is no replication issues found across the 6 PSCs. I've looked through the logs for the 6 PSCs and the 3 vCenters but cannot find anything. 

Is there is a way to re-create the data provider entry to re-establish link mode access from the web client GUI?

any help appreciated. 

0 Kudos
3 Replies
ashilkrishnan
VMware Employee
VMware Employee

Hi @rebelfalls ,

Please check vmdird logs to see if it reports any errors: /var/log/vmware/vmdird/

0 Kudos
rebelfalls
VMware Employee
VMware Employee

Hello @ashilkrishnan 

 

I checked the vmdird.log and see lots of these errors below. I did do a password reset in order to get the inventory services up. So thought these were related to that.

2020-07-16T06:09:54.871364+03:00 err vmdird t@0000: SASLSessionStep: sasl error (-13)(SASL(-13): authentication failure: client evidence does not match what we calculated. Probably a password error)
2020-07-16T06:09:54.871825+03:00 err vmdird t@0000: VmDirSendLdapResult: Request (Bind), Error (49), Message ((49)(SASL step failed.)), (0) socket ([32] 00.00.00.00<-00.00.00.00.)

2020-07-16T06:09:54.871939+03:00 err vmdird t@0000: Bind Request Failed ([32] 000.00.00.00.<-00.000.00.00) error 49: Protocol version: 3, Bind DN: "cn=xxx,ou=Computers,dc=vsphere,dc=local", Method: SASL

0 Kudos
ashilkrishnan
VMware Employee
VMware Employee

@rebelfalls 

LDAP Error (49) is caused by machine account password or SSO admin password issues. In this case, it seems like an issue with SSO admin user: ' Bind DN: "cn=xxx,ou=Computers,dc=vsphere,dc=local" '

Please perform steps 1 to 8(vCenter appliance) --> https://kb.vmware.com/s/article/2147280   . Once that's done, restart all the services

Steps 9 and later are not required as they are mainly related to machine account password. 

Hope that helps