jorge_c
Contributor
Contributor

OVA deployment - "Transfer failed: The OVF descriptor is not available"

Hello,

I am having a problem when trying to deploy an OVA file. The message "Transfer failed: The OVF descriptor is not available" is displayed. Any suggestions? Much appreciated.

38 Replies
rpas2915
Contributor
Contributor

Thanks,worked for me!

0 Kudos
afragop
Contributor
Contributor

Hello all,

I faced the same issue when I tried to deploy the ova using web client though Chrome.

By using Firefox, I had no issue and the ova deployed successfully.

Thx

Tasos

0 Kudos
ThepHuck
Enthusiast
Enthusiast

I ran into the same issue.  Fresh deployment of VCSA 6.5, tried deploying the vROps OVA using Chrome and received the "OVF descriptor is not available" error.

I restarted the content library via SSH to the VCSA:

service-control --stop vmware-content-library

service-control --start vmware-content-library

Tried again, still in Chrome (logged out, logged back in) and OVA deploy worked fine.

Thanks ~Luke @ThepHuck
phanke
VMware Employee
VMware Employee

We had the issue when we tried to deploy an OVA using Chrome when Web Client connected against the vCenter DNS alias name. After using the vCenter FQDN, the OVA deployment worked fine.

(N.b.: A colleague of mine suspected some certificate issue. Since Firefox has its own certificate store, this might be why IE and Chrome behave the same. I haven't tried to verify by using another browser, yet).

ace56
Contributor
Contributor

I am going to be honestly brutal here. I have had nothing but issues with vSphere 6.,5 things like VDP and vROPS. I can see why v6.7 came about so quickly. I am literally pulling my hair out with so many issues experienced, some as easy as deploying an OVA! VMWARE Support is also less than average as well in my opinion and not very helpful. It's almost as if they are not even trained up.

0 Kudos
petemb
Contributor
Contributor

Fresh install, 6.5u2 VCSA - was able to deploy an NSX Edge Client OVF using the HTML5 UI client in Chrome without issues. Had the same issue trying in Flash client in Chrome.

0 Kudos
MartinWest
Contributor
Contributor

Hi

I had the same issue.

In my case it was the time difference from my System to the VCSA.

As the time was the same on all Systems, the deployment runs without any problems.

Hope this help somebody!

Best regards

Martin

0 Kudos
dashoward
Contributor
Contributor

I too had the same issue.  I'm pretty sure know what the cause was as well. I began to deploy an OVF completed the process then deleted the VM.  Immediately upon deleting the VM I tried to recreate with a different OVF but with the same exact descriptor and received the error "OVF descriptor is not available". This was probably due to the fact that the library hadn't cleared the old descriptor from under my username. I read through all of the threads and the vExpert: Luke Huckaba final suggestion was the only one I tried and also successful the first attempt.

I logged off and logged back on and my OVF deployed immediately with the same descriptor as before. no problems at all. Also I was using Firefox as my browser the entire time.

0 Kudos
aabdulrahman0
Contributor
Contributor

Using the HTML5 client worked for me. I had been trying to deploy NSX for over a week using the Flash page. I tried with Chrome only.

0 Kudos
PeteLong
Contributor
Contributor

Ive seen this happen on 6.5 and 6.7 each time Ive simply redeployed to a HOST and not the cluster, and its worked fine.

VMware: The OVF Descriptor is Not Available

Pete

0 Kudos
kevin8611
Contributor
Contributor

I have the same problem, and i have solved it by redeploying it,selecting a specific host(if fails,try another host)

0 Kudos
RNAR
Enthusiast
Enthusiast

vSphere 6.5 latest patches (I think). I too was able to get it to work by just changing over to Firefox (v. 65.0.2).

Once again, a web browser makes for a pretty crappy operating system. Down with web apps!

iSamNC
Contributor
Contributor

This issue drove me nuts for weeks.  Kept getting Transfer failed: The OVF descriptor is not available. I can deploy fine from the host through the ESXi GUI but not VSphere: HTML5 nor Flash.  Tried FF, Safari, Chrome.  Finally got around to upgrading vSphere appliance and ESXi to latest and greatest 6.5 thinking that might fix it but no.  Checked that the FQDN is resolvable, etc.  Still couldn't get it to work.  Then I read in this thread someone tried IE and that solved it.  I really didn't think this was browser related but I fired up an old Windows 7 VM in Fusion and tried it in IE 11 and voila - worked fine.  It hurts my head that I have to use a 3,000 year old browser to deploy and OVF from vSphere.. but whatever.  Wanted to add this here.

iSamNC
Contributor
Contributor

Update.  IE worked.  One time.  The very next time I tried to deploy an OVF from the same system with the same browser during the same session if failed.

smccreadie
Enthusiast
Enthusiast

This solution posted by ThePhuck was a big help.  I am using VCSA 6.7 U3 and had the same "OVF descriptor is not available" error.  I restarted the VCSA, same issue.

I ran the commands to restart the content-library service and that solved it.

Thanks for the help.

jamachadog
VMware Employee
VMware Employee

in my case I checked everything proposed here, tried the html5 client and it worked.

0 Kudos
AvayaVMSU
Contributor
Contributor

AWESOME!!!  Simply amazing.  Thanks for the suggestion, @StoreThomas!

0 Kudos
AvayaVMSU
Contributor
Contributor

I had this problem with Chrome, so I tried FF.  It worked!  Then something else went wrong and I had to re-deploy.  This time FF had the problem.  I tried with IE and it worked.  IDK, but I hope I don't have to try again.  Maybe Opera - is that still a thing?

0 Kudos
omidkosari
Contributor
Contributor

My solution

In Firefox > Options > Privacy & Security > Certificates > View Certificates > Import

Then browse to the directory which contains .ovf and .cert files in my case "vSphere_Replication_OVF10.cert"

After importing the vSphere_Replication_OVF10.cert in to firefox certificates, everything works fine

0 Kudos