5mall5nail5
Enthusiast
Enthusiast

Losing my mind - need vSphere Web 6.0 client integration plugin to work

Hey all - have to deploy an OVF with prompts/dialogues that do not show in the thick client. I've been able to get it to work previously, but now there's no hope. Chrome 58 doesn't seem to care that it's installed. IE tells me the certs are bad. Firefox continuously loops saying it added the cert to its store. Super crazy frustrating. CIP has been uninstalled, reinstalled, installed as admin, etc. Rebooted machines. Tried other machines. Etc. Anyone have this working?

7 Replies
SaurabhRV
Enthusiast
Enthusiast

Tried Incognito mode in chrome?

Please consider marking this answer "correct" or "helpful" if you think your query have been answered correctly. http://www.linkedin.com/in/ saurabh-jain-a7b7bb9
0 Kudos
sirettn1
Contributor
Contributor

I resolved similar CIP problems by switching from Firefox 54.0 (32-bit) to Firefox Extended Release Support: Firefox ESR 52 - Mozilla Firefox Web Browser — Download Firefox Extended Support Release in your language — Mozilla .

kbulgrien4freed
Enthusiast
Enthusiast

Also, per my findings noted in Regarding Firefox revisions >= 39 and related 6.0 U3 Client Integration Plug-in issues , it seems that at least in Firefox, setting Options | Applications | vmware-csd to "Use VMware Client Integration Plug-in (default)" instead of "Always ask", creates issues even with the ESR browser.  This was particularly necessary to resolve issues when attempting to export a VM to an OVF.

0 Kudos
pwilsonagile
Contributor
Contributor

I'm having the same issue. I've tried incognito mode, and Chrome ignores the fact that I've already set it to allow Flash for my vcenter page. So it won't load the page once I log in because of that.

0 Kudos
Gidrakos
Hot Shot
Hot Shot

Just as a note for anyone else - using the Thick Client is almost always the better way to go about this - I tried for a month to get the plugin working correctly in my environment and just gave up - now I'm dreading the eventual need to upgrade to 6.5.

0 Kudos
mctom
Contributor
Contributor

You must backrev Firefox to the Extended Support Release version that they offer.  It still supports plug-in modules which is no longer accepted by Chrome.  Make sure that you uninstall the newer version first and reboot before installing the ESR version.  Your profile information is retained so bookmarks, saved passwords, etc. will be there after the install.

Firefox Extended Support Release for Your Organization, Business, Enterprise — Mozilla

There is a convoluted work-around that I found in a VMware KB article but it doesn't seem worth the trouble.

pwilsonagile
Contributor
Contributor

It looks like this has solved my issue! Thank you!

0 Kudos