VMware Cloud Community

Issues with vCenter 5.5 web client on Safari, Chrome and Firefox on Mac

Hi Guys,

I know this seems to have been covered a few times and a few months back, however, I am still having issues.

I cannot open a console to my virtual machines through Safari, firefox or chrome.

The Chrome error I am receiving is: Oops! Google Chrome could not connect to 'local_IP':7331.

Firefox replies: Firefox can't establish a connection to the server at 'local_IP:7331.

Safari replies: Safari can't open the page 'local_IP:7331,(with what looks like certificate id) because safari cannot connect to the server.

I have installed vCenter Appliance server 5.5

All browsers have been updated to their respective latest versions and all browsers will let me log in and i seem to have full functionality within the web client, just cannot open the console.

I have implemented the suggested fix on the below link, however this has not helped my cause.


My Mac is running Mavericks with no firewalls switched on.

I have downloaded and installed the client plugin when browsing to the web client interface: https://'local_ip':9443

I have tried removing the plugin for safari and re-installing, with no luck.

I have tried to open the console without installing the plugin, with no luck.

Now, funnily enough, I am also running Parallels on my Mac, running a Windows 8.1 VM.

I can open the console through both IE and firefox on my Windows VM (through Parallels) without any problems. Again, not running a firewall on my Windows VM which is why i don't believe it to be firewall or port related.

I can only speculate, that my issue is some how browser related, though I don't know how.

There is no antivirus on my Mac, so it can't be that. No proxies or anything like that.

I have restarted the vcenter server appliance numerous times. Still without luck.

Am i doing something wrong?

Hopefully someone can point me in the right direction or would have a fix that they know of. Any help would be greatly appreciated as i really am at wits end.

Thanks everyone!


6 Replies

I encountered this and adding an inbound firewall entry on the windows server hosting vcenter for tcp 7331 allowed the console to come up.




Hi Dennis,

if you use OS X Mavericks, check if you have Java installed and which version (open Terminal and type in java -version). if you get a poop up icon to install the JDK, go to Java SE Development Kit 7 - Downloads | Oracle Technology Network | Oracle and download the Java JDK for Mac OSX 64.

Then follow the KB from VMware VMware KB: HTML5 virtual machine console fails to open after restarting vCenter Server Appliance 5.5.

To make it simple, you might need a SFTP/SSH client like FUBU, and connect to the VCSA appliance via SSH, you need to enable SSH from the Admin tab on the vCenter Server Appliance management. When you completed the wrapper / conf file edit as per KB, reboot the VCSA appliance and the console will work.



0 Kudos

Did you ever get this all worked out?  I am having the same issues here as well but I am stumped.  A windows vm from the same Mac works fine but using the native browsers gives me this error.  I have followed the guidance in the KB but it didn't fix my issues.  I have a Windows vCenter not an appliance.

0 Kudos

HI qc4vmware,

No, unfortunately I never did get this resolved.

It was just taking up too much of my time to fix so I just ended up re-installing and configuring VMware vCenter appliance again,

That then fixed my issue. How it actually fixed it, I have got no idea.

Sorry I can't be of more help.

0 Kudos

This did the trick!  Thanks!

0 Kudos

The KB at VMware KB: HTML5 virtual machine console fails to open after restarting VMware vCenter Server Applia...

helped a lot

1. edit the file:


2. add this line at the 'set.default.*' area


3. restart vsphere-web-client

/etc/init.d/vsphere-client restart

0 Kudos