valot
Enthusiast
Enthusiast

Hardware status is displayed as "unknown" for certain sensors HPE G9 ESXi 6.5U2c with vCenter 6.5 Build 8815520

Hi all,

On  vCenter 6.5 Build 8815520 (appliance), Hardware status is displayed as "unknown" for certain sensors on HPE G9 ESXi 6.5U2c.

I used the last custom iso provided by HP (VMware-ESXi-6.5.0-Update2-9298722-HPE-preGen9-650.U2.9.6.8.3-Sep2018.iso) and I upgraded the HPE G9 with the last SPP also provided by HP (P11740_001_spp-2018.11.0-SPP2018110.2018_1114.38.iso).

Screenshot from vCenter ==>

pastedImage_6.png

pastedImage_0.png

pastedImage_3.png

Screenshot from Host ==>

pastedImage_1.png

I tried a lot of tips but nothing works.

Any idea ?

Or do I need to open a ticket to HPE or VMware ?

Thanks for help

0 Kudos
3 Replies
Shard201110141
VMware Employee
VMware Employee

Hi,

Sensor in below categories do not report their health status.

  • Presence sensors,
  • Disabled sensors,
  • Sensors with no reading available,
  • BIOS related,
  • Event-only sensors

How to identify sensor belongs to one of the above mentioned category

BIOS related sensor :Run 'esxcli hardware ipmi sdr list' command on the host. BIOS related sensor will have Entity-Instance column value "34.1"

Presence sensor : Run 'esxcli hardware ipmi sdr list' command and check below information for all sensors

  • Base Unit should be either 'enabled-discrete' or 'available-discrete'
  • Or Sensor Type should be 'Entity Presence'

Note : This data available only in 6.7 not in 6.5 U2

Disabled or No reading : Run /bin/cim-diagnostic.sh script.

In OMC_RawIpmiSensor class instances, check below fields for each entry:

ReadingStateUnavailable = true -> No reading sensors

Scanning disabled = true -> Disabled sensors

Event-only sensor : Use ipmitool and run below command:

'ipmitool sdr elist all'

Check last column for 'Event-Only'entry.

Open a ticket with vmware, I think there might be a PR open on this issue.

0 Kudos
diegodco31
Leadership
Leadership

Hello

Check if the following VMware KB article helps: VMware Knowledge Base

6.5 shows warning for hardware

Diego Oliveira LinkedIn: http://www.linkedin.com/in/dcodiego
0 Kudos
valot
Enthusiast
Enthusiast

I contacted the VMware support.

They told me this is a known issue describe in the KB 57171 ==> https://kb.vmware.com/kb/57171

I need to Wait and See 😞

0 Kudos