VMware Cloud Community

Error when remediate updates from update manager

Hi All,

when I tried to stage patches on a ESX 5.5 server using update manager. In the esxupdate.log , it says, "Error in copying from /altbootbank/vmware_f.v00 to /tmp/stagebootbank/vmware_f.v00: [Errno 2] No such file or directory: '/altbootbank/vmware_f.v00'") and i couldn't find vmware_f.v00 file on the altbootbank for some strange reason.

I tried to stage the patches on the same ESX server yesterday, it worked fine but it's not working today. I have checked the disk space and it's looks alright to me. Could you please help me to fix this issue.

/vmfs/volumes/c224d17b-5a25d564-71c0-2ae6513b2393 # pwd


/vmfs/volumes/c224d17b-5a25d564-71c0-2ae6513b2393 # ls -l *vm

ls: *vm: No such file or directory

esxupdate.log :

2016-10-19T09:32:30Z esxupdate: BootBankInstaller.pyc: INFO: Copying /altbootbank/vmware_f.v00 to /tmp/stagebootbank/vmware_f.v00

2016-10-19T09:32:30Z esxupdate: HostImage: ERROR: Failed to send vob install.stage.error: [Errno 27] File too large

2016-10-19T09:32:30Z esxupdate: esxupdate: ERROR: An esxupdate error exception was caught:

2016-10-19T09:32:30Z esxupdate: esxupdate: ERROR: Traceback (most recent call last):

2016-10-19T09:32:30Z esxupdate: esxupdate: ERROR:  File "/usr/sbin/esxupdate", line 216, in main

2016-10-19T09:32:30Z esxupdate: esxupdate: ERROR:    cmd.Run()

2016-10-19T09:32:30Z esxupdate: esxupdate: ERROR:  File "/build/mts/release/bora-3247226/bora/build/esx/release/vmvisor/sys-boot/lib/python2.7/site-packages/vmware/esx5update/Cmdline.py", line 144, in Run

2016-10-19T09:32:30Z esxupdate: esxupdate: ERROR:  File "/build/mts/release/bora-3247226/bora/build/esx/release/vmvisor/sys-boot/lib/python2.7/site-packages/vmware/esximage/Transaction.py", line 245, in InstallVibsFromSources

2016-10-19T11:28:22Z esxupdate: esxupdate: ERROR: InstallationError: ("set(['VMware_bootbank_misc-cnic-register_1.72.1.v50.1i-1vmw.550.0.0.1331820',

2016-10-19T11:28:22Z esxupdate: ', 'VMware_bootbank_sata-sata-sil_2.3-4vmw.550.0.0.1331820', 'VMware_bootbank_esx-base_5.5.0-3.95.4345813', 'VMware_bootbank_ata-pata-atiixp_0.4.6-4vmw.550.0.0.1331820'])", "Error in copying from /altbootbank/vmware_f.v00 to /tmp/stagebootbank/vmware_f.v00: [Errno 2] No such file or directory: '/altbootbank/vmware_f.v00'")

Error from update manager:

Stage patches to entity

The host returns esxupdate error code:15. The

package manager transaction is not successful.

Check the Update Manager log files and esxupdate

df -h

Filesystem  Size  Used Available Use% Mounted on

VMFS-5    131.8G  35.2G    96.5G  27% /vmfs/volumes/vh1027-datastore

VMFS-5      3.2T  3.1T    51.0G  98% /vmfs/volumes/Exchange

VMFS-5      9.1T  3.4T      5.7T  38% /vmfs/volumes/LocalVMs-SANdatastore

VMFS-5      4.5T 995.0M      4.5T  0% /vmfs/volumes/SRMVMs

VMFS-5      5.6T  5.6T      2.0G 100% /vmfs/volumes/JARIC-Data

VMFS-5    953.5G  2.6G    950.9G  0% /vmfs/volumes/ISOs

vfat      285.8M 201.6M    84.2M  71% /vmfs/volumes/522ed803-9a2f06c1-4f0d-e4115b96a26a

vfat      249.7M 177.1M    72.6M  71% /vmfs/volumes/f6df1370-2b300aa7-22f1-0c9490b7ada8

vfat        4.0G  47.9M      4.0G  1% /vmfs/volumes/54ef6427-e60090b2-ffd5-e4115b96a26a

vfat      249.7M 161.6M    88.1M  65% /vmfs/volumes/c224d17b-5a25d564-71c0-2ae6513b2393



0 Kudos
1 Reply

Just thought I would answer this as I just ran into the same issue.

[Errno 2] No such file or directory: '/altbootbank/vmware_f.v00'")

To fix this I copied the file from a working host that was the same version to /altbootbank/ and /bootbank/ (had to do both in my case).

Just used WinSCP to move the file over.

The next time I ran Remediate it worked fine.

0 Kudos