Sachchidanand
Enthusiast
Enthusiast

Enable VMware vCenter High Availability

Jump to solution

Hi

How to enable VMware vCenter High Availability in VCSA 6.7 as in services, it's showing disabled and stopped. While starting the service it giving error "Operation not allowed on a disabled service".

see attachment.

BR

Sachchidanand

0 Kudos
1 Solution

Accepted Solutions
Vijay2027
Expert
Expert

Did you login flex client?

pastedImage_2.png

pastedImage_1.png

View solution in original post

0 Kudos
14 Replies
Vijay2027
Expert
Expert

Login to web-clinet --> Home --> Administration --> Services and click on actions.

Set the service to Automatic or manual.

pastedImage_0.png

0 Kudos
Vijay2027
Expert
Expert

Or ssh into appliance and start vcha service.

pastedImage_0.png

0 Kudos
Sachchidanand
Enthusiast
Enthusiast

Hi Vijay,

Thanks for the reply. There is no services option under Administrator. please see attachment. It's VCSA 6.7.

BR

Sachchidanand

0 Kudos
Vijay2027
Expert
Expert

Login to web-clinet --> Home --> Administration --> System Configuration --> Services

0 Kudos
Sachchidanand
Enthusiast
Enthusiast

Hi Vijay,

Thanks, but it's unable to start vcha service through cli...see the attachment.

BR

Sachchidanand

0 Kudos
Sachchidanand
Enthusiast
Enthusiast

Please see the attachment in previous reply. I am unable to find "System Configuration" under "Administration".

0 Kudos
Vijay2027
Expert
Expert

Did you login flex client?

pastedImage_2.png

pastedImage_1.png

View solution in original post

0 Kudos
tekkanor
Contributor
Contributor

Hi,

I have no 6.7 in place, but you followed this, correct?

https://docs.vmware.com/en/VMware-vSphere/6.7/vsphere-esxi-vcenter-server-67-availability-guide.pdf

At page 77 it says:

"

Procedure

1 Log in to the Active node with the vSphere Web Client.

2 Right-click the vCenter Server object in the inventory and select vCenter HA Settings.

3 Click Configure.

4 Select the Basic configuration option and click Next.

This option is available only if your environment meets prerequisites for the Basic option.

"

Did you followed this?

Also, important the bold words, with the prerequisites described in previous pages of the doc...

HIH in some way,

Gianluca

tekkanor
Contributor
Contributor

Also important the note at the beginning of the doc, that explains "vSphere Client" and "vSphere Web Client", as not all functionalities are in both, it seems:

"

The instructions in this guide are specific primarily to the vSphere Client (an HTML5-based GUI). Most instructions also apply to the vSphere Web Client (a Flex-based GUI).

For the workflows that significantly differ between the two clients, there are duplicate procedures. The procedures indicate when they are intended exclusively for the vSphere Client or the vSphere Web Client.

"

In your case it seems you have to explicitly use vSphere Web Client (a Flex-based GUI)

Gianluca

Sachchidanand
Enthusiast
Enthusiast

Hi

Thanks. It's because of different vsphere client option. After login with Flex client, all option are there.

BR

Sachchidanand

0 Kudos
SP2911
Contributor
Contributor

Hello ,

One quick question, do you have the VCHA set up already or you in a process of creating the VCHA.

If it is already set up,

then a take a ssh to the appliance

and type the command.

Service-control --status --all

And provide us the output

0 Kudos
SP2911
Contributor
Contributor

Hello ,

One quick question, do you have the VCHA set up already or you in a process of creating the VCHA.

If it is already set up,

then a take a ssh to the appliance

and type the command.

Service-control --status --all

And provide us the output

0 Kudos
Vijay2027
Expert
Expert

And all the features will be available in html5 client starting 6.7U1 which will be available later this year.

https://blogs.vmware.com/vsphere/2018/08/under-the-hood-vsphere-6-7-update-1.html

0 Kudos
abugeja
Hot Shot
Hot Shot

Is it possible to provide Site (data centre redundancy)  for vCenter in 6.7 now? From what I can see it only provide same site and they need to live on the same VM cluster as well.

0 Kudos