VMware Cloud Community
trsorrell
Contributor
Contributor

ESXi 5.5 host LOCKDOWN mode grayed out

I just upgraded 1 of my hosts to 5.5 and during the upgrade it rebooted but I'm not able to connect to it with VCenter anymore. I removed it and tried re-adding but it says it can't connect. I can ping it. I cannot connect to it with the Vsphere client either. On the host when I go into configuration it has the lockdown mode grayed out. I'm suspecting that I cannot connect to it because it's in lockdown mode? If it's grayed when I directly log into the host how do I connect and disable lockdown mode??

I log into the host directly with the root account.

Reply
0 Kudos
6 Replies
admin
Immortal
Immortal

This wold be the way to check lock down mode from shell..

ESXi 5.x and 4.1

  • To check if Lockdown mode is enabled: vim-cmd -U dcui vimsvc/auth/lockdown_is_enabled
  • To disable Lockdown mode: vim-cmd -U dcui vimsvc/auth/lockdown_mode_exit
  • To enable Lockdown mode: vim-cmd -U dcui vimsvc/auth/lockdown_mode_enter

Enabling and disabling can be done using DCUI also.

~dGeorgey

Reply
0 Kudos
trsorrell
Contributor
Contributor

Ok I will try the shell in the morning. I can't use the DCUI because it's grayed out.

Reply
0 Kudos
sicnarf_latosa
Enthusiast
Enthusiast

Any other option to fixed this issue? I encounter same issue.

After upgrading 5.5 to up3a Lockdown mode is grayed out host is not pingable and cannot connect to VC. I try to rebuild again but no lock same error I encounter.

Reply
0 Kudos
sicnarf_latosa
Enthusiast
Enthusiast

Hi Guys,

Lockdown mode is grayed out if the host is not connected to CV. trsorrell did your issue resolved? if not check network configuration IP's/MTU of VSS/VDS should be the same with management network/vmotion portgroup. Check the logs as well possible driver issue 

Reply
0 Kudos
RanjnaAggarwal
VMware Employee
VMware Employee

hi, if your esxi host is not connected with vCenter then you cannot enable or disable the lockdown mode and that is why it is greyed out.

Regards, Ranjna Aggarwal
Reply
0 Kudos
apiceno
Contributor
Contributor

I had the same issue in my development environment. I resolved my issue by updating vcenter to the latest build once i did that i was able to join the esxi host back to vcenter. I believe the rule of thumb is update vcenter before esxi hosts. Hope this helps.

Reply
0 Kudos