JRT68
Contributor
Contributor

Does the 6.0U2 Migration Tool Support Linked Mode VCs?

Hi,

The short questions are: does the 6.0U2 migration tool support linked mode VCs? And since the tool maintains the personality of the VC Avamar should continue to work without issue?

The real question is more nuanced so please see the information below.

I need to upgrade my VCs to 6.0U2 and I looking at various ways to deploy these new VCs either spin-up new and forklift all clusters over or go through the U2m migration tool, I am trying to figure out the best path and have a few questions.

My current environment is three Windows 2008R2 servers with vCenter 5.1 U2 (build 1473063) in a linked mode group with VUM and all components installed on each server except for separate external SQL databases on three separate DB servers. I need to get them up to 6.0 U2 and preferably running on the VCSA with linked mode. We have a very dispersed environment with stores around the country and about (180) 3-node clusters spread across two of the VCs. We also use Avamar for backups at these locations so that needs to be maintained.

From my research, I know that to use linked mode with 6.0U2 I need to have external PSCs so could I theoretically perform a migration this new tool in this manner?

Upgrade all VCs to 5.5 à Deploy new OS (x3) with the 5.5 SSO for all VCs and point services to new SSO à Run 6.0U2 migration tool on each of the three VCs. If this does not work I will need to deploy three new VCs and use PowerCLI to move all clusters one at a time over to the new VCs and that is very time consuming.

Does anyone have anyone have any information on the best course of action here?

Thanks for the help!

0 Kudos
3 Replies
msripada
Commander
Commander

Hello JRT68

You need to break linkedmode as in vsphere 6.0, there is no linkedmode, there is ELM.

Please find the FAQ for migration and search for linkedmode -> question 27

FAQ: Migrating vCenter Server 5.5 to vCenter Server Appliance 6.0 U2m (2146439) | VMware KB

If the SSO domain is same vSphere.local, vCenter 6.0 should have the Enhanced linkedmode.

Thanks,

Murali Sripada

0 Kudos
JRT68
Contributor
Contributor

Murali,

Thanks for the reply.

This is VC 5.1 so it wouldn't it be System-Domain. If I upgrade to 5.5 will the SSO domain be changed to Vsphere.Local?

I am looking at this page below which describes how to go from 5.5 embedded PSC to 6.0 external. I have three Windows 5.1 U2 VCs in linked mode and will need to take them to VCSA 6.0U2 external PSC in enhanced linked mode.

https://haveyoutriedreinstalling.com/2016/04/10/migrating-from-embedded-sso-to-external-psc/

From a high level does this look like the proper process?

  1. Upgrade to all 3 VCs to 5.5
  2. Break SSO Linked Mode
  3. Deploy three new Windows OS and install SSO service
    1. Deploy first as a standalone
    2. Deploy second and third as a multisite
  4. Point the Inventory Service, VC Server, and Web Client to each respective SSO server.
  5. Run the VCSA 6.0U2m migration tool on each VC
  6. Connect enhanced link mode

What happens to the Update Manager since it is not embedded in the VCSA on 6.0? Do I need to install new servers and register them prior to step 5?

Thanks for the assistance!

0 Kudos
msripada
Commander
Commander

Sorry for the delay.

All steps are good except the first and second. You can break the linkedmode first and then upgrade the vcenters.

Upgrading vCenter 5.5 in Linked Mode to 6.0

0 Kudos