sweehan
Enthusiast
Enthusiast

Deploy vcenter 6 with external psc. firstboot script execution error.

Jump to solution

Hi

I've successfully deploy external PSC. When I continue to deploy the vcenter appliance I got the error firstboot script execution error. The ssl certificate does not match when connecting to the vcenter single sign-on.

I refer to this blog for troubleshooting https://techbrainblog.com/2015/10/03/vcsa-6-0-installation-issues-firstboot-script-execution-error/ but when deploying the vcenter the ip of the external PSC i enter was correct. Also i checked the DNS and both PSC and Vcenter name able to resolve correctly.

If I were to try and install the vcenter again, could i just power down the failed Vcenter and delete it?

0 Kudos
1 Solution

Accepted Solutions
JailBreak
Hot Shot
Hot Shot

Hi,

This is a new installation, or are you trying to re-point to a external PSC within your site?

If to re-point, check this: How to repoint vCenter Server 6.0 between External PSC within a site (2113917) | VMware KB

Also dont forget that the old installation could have the PNID(primary network identifier) with the FQDN or the IP address. Is not the same and they work different.

If a new installation, try to follow this:

https://featurewalkthrough.vmware.com/#!/vsphere-6-0/vcenter-server-install/vcsa-6-0-install-with-ex...

Luciano Patrão

vExpert vSAN, NSX, Cloud Provider, Veeam Vanguard
Solutions Architect - Tech Lead for VMware / Virtual Backups

________________________________
If helpful Please award points
Thank You
Blog: https://www.provirtualzone.com | Twitter: @Luciano_PT

View solution in original post

0 Kudos
2 Replies
JailBreak
Hot Shot
Hot Shot

Hi,

This is a new installation, or are you trying to re-point to a external PSC within your site?

If to re-point, check this: How to repoint vCenter Server 6.0 between External PSC within a site (2113917) | VMware KB

Also dont forget that the old installation could have the PNID(primary network identifier) with the FQDN or the IP address. Is not the same and they work different.

If a new installation, try to follow this:

https://featurewalkthrough.vmware.com/#!/vsphere-6-0/vcenter-server-install/vcsa-6-0-install-with-ex...

Luciano Patrão

vExpert vSAN, NSX, Cloud Provider, Veeam Vanguard
Solutions Architect - Tech Lead for VMware / Virtual Backups

________________________________
If helpful Please award points
Thank You
Blog: https://www.provirtualzone.com | Twitter: @Luciano_PT
0 Kudos
sweehan
Enthusiast
Enthusiast

I've re-try. It turns out that the reverse dns for the PSC and Vcenter not added. Because the failed vcenter installation i entered the ip of the PSC instead of the FQDN.

After I removed the failed Vcenter from the PSC record and added the reverse dns record for psc and vcenter, the installation was successful.

0 Kudos