mechgt
Enthusiast
Enthusiast

Cannot type (using keyboard) on vSphere Web Client

This is very strange:

I just deployed a new vSphere 6.0 VCSA and am using the webclient (currently Firefox on Win 10) to configure the system.  When I create a new object, there are dialog boxes that require me to input data; for example "New Distributed Port Group" prompts me to input the port group name.  The problem is that the web client is not receiving my keystrokes.  The workaround is everytime I run into a dialog box requiring keystrokes (such as inputting an object name, etc.) I have to click the Windows start button (changing focus away from the browser window) then re-click on the input box and begin typing and it works normally.... until the next dialog box is displayed where I have to click away, then return to finish entering data.  I've seen this before on another completely separate system but never chased down the solution.

Anyone else seen this and have a recommendation?

Tags (1)
38 Replies
DCARichM
Contributor
Contributor

I have both 32- and 64-bit Flash players installed and am still having this problem.

0 Kudos
criticaltgraham
Contributor
Contributor

Same issue here. vCenter virtual appliance (version 6.5), web client is Firefox (latest) on Windows 10.

0 Kudos
WackyWRZ
Contributor
Contributor

I'm also seeing this issue in Firefox 58 and 59.  I've opened a bug report on bugzilla since it seems to be related to Firefox as all other browsers seem to work fine.  Bug report is here: 1435542 - VMware vCenter 6.5 Flash web client not accepting keyboard input

0 Kudos
SPeedYdr
Contributor
Contributor

It is unbelievable that a post six months old still has not gotten any attention from the vmware team. I keep searching for possible solutions and end in the same place, Firefox doesn't work, Chrome doesn't work, Edge kinda works, crashes often and yet no has push the restore button yet and restore the thick client?

0 Kudos
koakeson
Contributor
Contributor

Installing Firefox 32bit on Windows 10 and making sure I ran the 32bit version solved the problem for me.

I will also be talking to our team members about this and getting it documented.

0 Kudos
Bit101
Enthusiast
Enthusiast

The same problem here

- whats happening?

-are there any bug-fixes från VMwware or workarounds?

0 Kudos
mdanshin
Contributor
Contributor

Have same issue on VCenter Web Client 6.5 and Firefox Quantum 60.0 (64-bit). Please help!

0 Kudos
Tittan
Contributor
Contributor

In my case firefox quantum 32bits not resolved the issue.

0 Kudos
JoseMesquita
Enthusiast
Enthusiast

Same issue here, using vSphere 6.7.

The Web Client works fine on Chrome 67.0.3396.99 x64 build, and IE11 on a Windows Server 2012 x64 acting as a workstation.

However, FireFox .52.0 x64 will exhibit the "cannot type " behavior.

Quick fix:

Uninstall FireFox x64 and install the x86 version.

The vsphere 6.5. and 6.7 authentication plugins will not work with FireFox above version 52. I spent hours on this, trying a couple of tricks like installing the vCentar root CA certificates on the Windows server workstation. Nothing worked for me.

That said, the authentication plugin works just fine with Chrome 67.0.3396.99 x64 and IE11,

0 Kudos
krigul
Contributor
Contributor

My temporary fix is to minimize the window and then maximize it, but you need to do this everytime you need to add text.

StephenMoll
Expert
Expert

Easier than that, click the task bar then click back into the field you want edit. It seems keyboard input is re-enabled once the browser application gets focus again.

IRIX201110141
Virtuoso
Virtuoso

Same/Another workaround is to click into the address or search field of the browser and than back into the flash overlay. With that you get the focus back and can type into the fields.

Regards,

Joerg

0 Kudos
KyleLouden
Contributor
Contributor

I also encountered this same issue when accessing my VCSA 6.5.0.5100 through the vSphere (Flash) web client through 64-bit FireFox 64.0

I simply needed to rename the VMs visible name in the VM inventory and when accessing the flash client I couldn't erase/modify the field using my keyboard, it's like any key I hit did not register or do anything. I have encountered this before in other fields, finally decided to look into it.

I was able to modify the VM names through the HTML5 vSphere Web client. When accessing the vCenter it does say that the HTML5 client has "partial functionality" I am not sure what can/can't be seen/done; however, using the HTML5 client may be a workaround for those using vCenter 6.5 or later. This was my first time accessing the HTML5 client and I might consider switching to using it primarily.

0 Kudos
universeman
Contributor
Contributor

Just to confirm, the HTML5 client does work without exhibiting this issue. I can also confirm the issue still occurs for me with 64bit Firefox and a 64bit Flash plugin. My current workaround is to have 64 bit Firefox for all my normal usage, and a separate install of Firefox Developer Edition (32-bit) to load the vSphere pages.

Also, there has been no traction on the Firefox bugzilla entry since my comment 7 months ago, so workarounds will probably be the only solution until the Flash client is gone.

https://bugzilla.mozilla.org/show_bug.cgi?id=1435542

0 Kudos
FDHTHR
Contributor
Contributor

I workarounded the issue : If you click on lego brick at the left of the url addr

and allow adobe flash to run, you retrieve the working keyboard.

In my case, I couldn't use keyboard but mouse was working (eg to increase vm disk size)

Firefox does not seem to remember the "allow" although I checked to remind it ...

HTH

Cheers

Th

nkhan2500
Contributor
Contributor

Worked for me.

0 Kudos
slivovics
Contributor
Contributor

This actually works !

0 Kudos
Alex_Romeo
Leadership
Leadership

Hi,

it's an error that hasn't been solved even in version 6.5

When it happens, I open the notepad and write some random letters, so I go back to writing on the web interface and it works.

Best regards

Alessandro Romeo

Blog: https://www.aleadmin.it/
0 Kudos
GBartsch
Enthusiast
Enthusiast

The easiest way to deal with this it to switch to another tab in the web browser, and then switch back.

It appears that tab switching fixes the issue 100% of the time.

Yeah, it's annoying.

0 Kudos