VMware Cloud Community

Can't rejoin VCenter 6.5 to AD domain dns error

Hey all,

We tried rejoining our VCenter 6.5 server appliance do our Active Directory domain, from the psc console and from vcenter administration pane.

This VCenter had a computer account in the domain, which we have removed, and an old keytab file in the VCenter server itself.

After trying add the VCenter to the domain with username with the right permissions, we had the following error:

"failed to join to active directory domain for localhost. Please set DNS properly in the appliance"

We also have found this KB article 

"Please set DNS properly in the appliance" error joining Platform Services Controller to an AD Domai...

However, none of the described causes is not the cause in our case.... The error is something about af adapter or something like this.... and we have got error codes 30 and 31


Trying to remediate this, we tried the following tests:

  1. the DNS is properly set in the server appliance and we could resolve the DC from the domain name
  2. LDAP queries, DNS and Cifs packets did cross the organization FW and the VCenter internal FW
  3. The AD user has the right permissions to join the appliacne to the domain
  4. The krb5.conf file containing the domain
  5. The functional level of the domain is supported

What is your advice?

have anyone came across this? 



0 Kudos
0 Replies