tbfichter
Contributor
Contributor

Boot From San Host Profile Noncompliant

Jump to solution

So I just finished working through all the errors and customization of a new Host Profile, but I am still having an issue with the host saying non-compliant. The host boots from san and has a local SSD. Those two drives are throwing errors of "Host state doesnt match specification: device naa:XXX parameters needs to be reset." I have performed the steps in KB 2002488 but it did not fix the issue.

Any help would be greatly appreciated.

0 Kudos
1 Solution

Accepted Solutions
crawfordm
Expert
Expert

In the "Enable/Disable Profile Configuration" under storage, expand and deselect everything that has naa.xxx in it.  Here is the way mine is configured.

hp01.jpg

------------------------------------------------------------------ If you found this answer useful please consider the use of the Helpful or Correct buttons to award points. Thanks, Marc Crawford CCNA, MCSE, MCTS, A+, Net+, Sec +, VCA-WM, VCA-DCV, VCA-Cloud, VCA-NV, VCP-NV, VCP-DCV, VCP, VCAP5-DCA http://gplus.to/marccrawford http://blog.marccrawford.com @uber_tech_geek

View solution in original post

0 Kudos
4 Replies
crawfordm
Expert
Expert

I have seen that error many times and usually a reboot of the host will fix it.

Which version of vSphere are you running?

Here is a thread of someone having the same issue - Re: Host Profiles playing up in vSphere 5

Please mark helpful & correct answers.

------------------------------------------------------------------ If you found this answer useful please consider the use of the Helpful or Correct buttons to award points. Thanks, Marc Crawford CCNA, MCSE, MCTS, A+, Net+, Sec +, VCA-WM, VCA-DCV, VCA-Cloud, VCA-NV, VCP-NV, VCP-DCV, VCP, VCAP5-DCA http://gplus.to/marccrawford http://blog.marccrawford.com @uber_tech_geek
0 Kudos
tbfichter
Contributor
Contributor

I am running vCenter 5.5u2 build 2001466. The hosts have been rebooted several times since applying the profile with no change. Thanks for the link, unfortunately they were not helpful as I have done all those suggestions already.

0 Kudos
crawfordm
Expert
Expert

In the "Enable/Disable Profile Configuration" under storage, expand and deselect everything that has naa.xxx in it.  Here is the way mine is configured.

hp01.jpg

------------------------------------------------------------------ If you found this answer useful please consider the use of the Helpful or Correct buttons to award points. Thanks, Marc Crawford CCNA, MCSE, MCTS, A+, Net+, Sec +, VCA-WM, VCA-DCV, VCA-Cloud, VCA-NV, VCP-NV, VCP-DCV, VCP, VCAP5-DCA http://gplus.to/marccrawford http://blog.marccrawford.com @uber_tech_geek
0 Kudos
tbfichter
Contributor
Contributor

Not sure how I missed disabling PSA Device Setting checkbox so many times. That did it for me, thanks so much.

0 Kudos