VMware {code} Community

"Cannot open /dev/vmmon: No such file or directory" error when powering on a VM - Rocky Linux

Hi everyone!
First of all, sorry if I say something wrong, my English level is basic and I've learned it in the most part by myself.

My laptop settings
I use a Rocky Linux 8.7 (Green Obsidian) x64 in dual boot with Windows 11 x64 both of them with Secure Boot Enabled and in AHCI Mode on BIOS. Virtualization it's also enabled on BIOS.
It's an Acer Nitro 5 with Intel Core i5-8300H @4.00Ghz, 8GB DDR4 RAM, SSD512GB NVME and Nvidia GeForce GTX 1050 Mobile.
I had the problem at Rocky Linux so, lets focus on it.

The problem (with images attached)
I've installed VMWare Player 17 with success but when I try to open a virtual machine it shows me the following two messages:
1. Error: Could not open /dev/vmmon: No such file or directory.
Please make sure that the kernel module 'vmmom' is loaded.
When I click to close or in OK it shows me the message two bellow.

2. Error: Failed to initialize monitor device.
When I click to close or in OK it closes the WMWare Player 17.

The possible solution I tryed but it didn't work out
I've found this link and try to follow the steps: https://kb.vmware.com/s/article/2146460

1. Terminal comand:
openssl req -new -x509 -newkey rsa:2048 -keyout MOK.priv -outform DER -out MOK.der -nodes -days 36500 -subj "/CN=VMware/"

When I run it on terminal it shows me:
Generating a RSA private key
writing new private key to 'MOK.priv'

2. Terminal comand: sudo /usr/src/linux-headers-`uname -r`/scripts/sign-file sha256 ./MOK.priv ./MOK.der $(modinfo -n vmmon)

When I run it on terminal  and type my password it shows me:
sudo: /usr/src/linux-headers-4.18.0-425.3.1.el8.x86_64/scripts/sign-file: command not found 


After that, its impossible tu run the other following commands, none of them are working.
I hope some friend could help me here.
Thanks any way and I wish the best for us all, greetings!

0 Kudos
2 Replies
VMware Employee
VMware Employee

Your post needs moving to the area for Workstation Player, so I have reported it to the volunteer moderators.



Although I am a VMware employee I contribute to VMware Communities voluntarily (ie. not in any official capacity)
VMware Training & Certification blog
0 Kudos

Thank you and sorry for my mistake!

0 Kudos