VMware Communities
stodola
Contributor
Contributor

workstation pro 14 upgrade from ver 12 produces blank screen when running existing VM's

Upgraded from ver 12 pro. All VM's were working fine, 14 upgrade just gives a blank vm screen now

machine is windows 10 pro, fully patched with 32 gb memory

restored host machine back to ver 12, and restored the vm also, works now

Tags (1)
49 Replies
Andre-n
Contributor
Contributor

Any news for a solution ?

Thanks

Andre

Reply
0 Kudos
jeffpc
Contributor
Contributor

Has this issued been found?  I saw 14 on sale, but not going to upgrade if so many having trouble so will stay at 12 pro

Reply
0 Kudos
Harwise
VMware Employee
VMware Employee

We are following the guide of the MSDN article Categorizing Layered Service Providers and Applications (Windows)  to solve this problem.

Reply
0 Kudos
EARNEST0
Contributor
Contributor

I have the same issue, winsock reset did not help.

Reply
0 Kudos
Harwise
VMware Employee
VMware Employee

Please upload the log files. Both the UI log file and the VM log file are needed, paths of which can be seen in About dialog.

Reply
0 Kudos
TrevorAnz
Contributor
Contributor

Similar problems, although not related to an upgrade. Clean install of VMWare 14 Pro on a Win 10 Pro x64 machine.

I loaded some provided WS 2012 VM's which worked fine last week, but this week I only get the black screen when entering any of the VMs. (No changes made to the host machine)

The VM's look to be running OK and the expected display is seen in the 'reduced' view in the VMWare Workstation UI.

Logs are attached for one of the servers on startup.

I haven't tried the Winsock tweak as reinstalling VMWare is a bit of an obstacle. Also, nothing has been deliberately changed on the host machine since last week.

Reply
0 Kudos
Harwise
VMware Employee
VMware Employee

Log shows that the Win Socket in your environment was not working correctly.

2017-12-05T14:39:16.510+13:00| mks| W115: SOCKET failed to make fd 1968 non-blocking!: 10038, An operation was attempted on something that is not a socket

2017-12-05T14:39:16.541+13:00| vmx| W115: SOCKET failed to make fd 1816 non-blocking!: 10038, An operation was attempted on something that is not a socket

And "VMware Authorization Service" seems not working normally, which I believe was caused by the same Win Socket error.

2017-12-05T14:47:42.666+13:00| host-3696| I125: Cnx_Connect: Error message: Failed to read vmware-authd port number: Cannot connect to VMX: C:\Training\EMS 3.2 APUG\wx64dts01a\wx64dts01a.vmx

TrevorAnz
Contributor
Contributor

Harwise  Thank you - the winsock reset has fixed the issue, even without reinstalling VMWare.

Reply
0 Kudos
LukeKuss
Contributor
Contributor

All,

I ran into the same black screen issue on my Windows vm's while moving from VMware Workstation version 12 to 14.   I was able to resolve by following the resolution highlighted in VMware KB 2034627  - VMware Knowledge Base

Resolution


To resolve this issue:

  1. Boot the virtual machine into Safe Mode.
  2. In the Device Manager, change the driver for the VGA card to the standard MS VGA Driver.
  3. Reboot the virtual machine.
  4. Uninstall the wrong version of VMware tools.
  5. Install the correct version of VMware tools.

Luke Kuss

ErnestK
Contributor
Contributor

Reply
0 Kudos