surti10
Contributor
Contributor

when i assign static ip (nat or hostonly), guest has not ip mapped

Hi,

I have modified the dhcpd.conf file (vmnet8 and vmnet1) to indicate a static ip for my virtual machine (vmware workstation in rhel7 host) .

####### VMNET DHCP Configuration. End of "DO NOT MODIFY SECTION" #######

host MyVM {

        hardware ethernet 00:0C:24:51:FF:3F;

        fixed-address 192.168.235.150;

}

After restarting the vmware service and starting the virtual machine, it has no IP mapped. On the other hand, if I reset the initial configuration, an IP is assigned.

Can anybody help me?

Thanks,

0 Kudos
4 Replies
gimmely
Hot Shot
Hot Shot

If you want to set a static IP, why use DHCP at all?

0 Kudos
surti10
Contributor
Contributor

I've always set it up like this so, how should I configure it? (I do it through terminal, I have no graphical interface)

I have detected that, upon lifting the vmware.service service, there is the following error,

vmware[28007]: Starting VMware services:

vmware[28007]: Virtual machine monitor[  OK  ]

vmware[28007]: Virtual machine communication interface[  OK  ]

vmware[28007]: VM communication interface socket family[  OK  ]

vmware[28007]: Blocking file system[FALLÓ]

vmware[28007]: Virtual ethernet[  OK  ]

vmware[28007]: VMware Authentication Daemon[  OK  ]

systemd[1]: vmware.service: control process exited, code=exited status=1

systemd[1]: Failed to start SYSV: This service starts and stops VMware services.

Could this error be related?

Thanks!!!

0 Kudos
RDPetruska
Leadership
Leadership

1a.  Is that IP address within the subnet range of that VMnet?

1b.  You will need a different one for the NAT (VMnet8) and Host-Only (VMnet1) networks, by the way.

2. Does that MAC address match the one for that guest in the vmx file?

0 Kudos
surti10
Contributor
Contributor

In other installations I have done it through NAT (vmnet8), without having to configure another adapter.

The MAC address is the one that appears in the .vmx file, and the network configuration is as follows,

###### VMNET DHCP Configuration. Start of "DO NOT MODIFY SECTION" #####

allow unknown-clients;

default-lease-time 1800;                # default is 30 minutes

max-lease-time 7200;                    # default is 2 hours

subnet 172.16.78.0 netmask 255.255.255.0 {

        range 172.16.78.128 172.16.78.254;

        option broadcast-address 172.16.78.255;

        option domain-name-servers 172.16.78.2;

        option domain-name localdomain;

        default-lease-time 1800;                # default is 30 minutes

        max-lease-time 7200;                    # default is 2 hours

        option netbios-name-servers 172.16.78.2;

        option routers 172.16.78.2;

}

host vmnet8 {

        hardware ethernet 00:50:56:C0:00:08;

        fixed-address 172.16.78.1;

        option domain-name-servers 0.0.0.0;

        option domain-name "";

        option routers 0.0.0.0;

}

####### VMNET DHCP Configuration. End of "DO NOT MODIFY SECTION" #######

host myVM {

        hardware ethernet 00:0C:29:52:FE:1F;

        fixed-address 172.16.78.128;

}

Thanks,

0 Kudos