tea5998
Contributor
Contributor

vmware workstation rolling back action download error

I just do it but it says that was "VMware workstation setup Wizard ended up prematurely

Vmware workstation Pro setup Wizard ended prematurely because of an error. Your system has not been modified.To install this program at a later time, run into Setup Wizard again. click the finish button to exit the Setup wizard" it. how can I do?

0 Kudos
13 Replies
RDPetruska
Leadership
Leadership

Did you verify the md5 checksum of the downloaded installer?  And have you run it "As Administrator"?

What version of Workstation, and what host OS version?

0 Kudos
tea5998
Contributor
Contributor

I don't know but I didn't anything

0 Kudos
tea5998
Contributor
Contributor

I don't know it just do it

0 Kudos
continuum
Immortal
Immortal

Untitled.png

does not look like a valid path ...

Do you need support with a recovery problem ? - send a message via skype "sanbarrow"
0 Kudos
tea5998
Contributor
Contributor

I can't find you in the skype. where is it

0 Kudos
continuum
Immortal
Immortal

Do not call me via skype again

Do you need support with a recovery problem ? - send a message via skype "sanbarrow"
0 Kudos
grey666
Contributor
Contributor

Having same issue on Win7 64bit host machine on which VMware worked fine before. Have you been able to find a solution?

0 Kudos
Susie201110141
VMware Employee
VMware Employee

What's your old ws version which worked well?Which ws version did you upgrade to ?
Could you upload your support logs ?

0 Kudos
grey666
Contributor
Contributor

Thanks for your reply,

15.0.4 and all before that worked fine, tried to upgrade to 15.5.

Uploaded the failed install log here: VMware Workstation Setup Wizard ended prematurely because of an error. - Nothing left in the main folder as it removed the old working version during update, and now won't let me install any version again even 15.0.4

Chertov2019
Contributor
Contributor

Is this the first time you install VMWare workstation on this computer? I personally was helped by reinstalling Windows 10 and saving my personal files

0 Kudos
dasfl34
Contributor
Contributor

Having the same issue!

0 Kudos
Mits2020
Hot Shot
Hot Shot

Most probably there are WS previous installations leftovers in your host. Try performing a complete uninstall using the instructions in Uninstall Workstation Pro from a Windows Host .

If this fails too, you must cleanup your Windows Installer database, which in Win10 is done using https://support.microsoft.com/en-us/help/17588/windows-fix-problems-that-block-programs-being-instal... 

0 Kudos
dasfl34
Contributor
Contributor

I tried both options it didn't work. I have installed VMware in the past. Maybe there could be some left over files.

0 Kudos