Chaitanyakumar_
Enthusiast
Enthusiast

vmware workstation 100% disk usage

Jump to solution

Hi All,

I have amd fx 8350 processor with 12 gb ram and 1 tb hard disk(not ssd). I have created some 10 vms and when i try to start few of them suddenly disk usage increases to 100%. I dont turn them all at a time, I give some time between each vm poweron. Still same issue happens. Moreover, even after sometime, after turning on my vms, same issue happens. on my host windows machine, disk usage is 100% most of the time. because of that my vmware workstation hangs and I am not able to do anything. I have to wait till disk utilization is free again. I have disabled windows search on my host machine but no luck.

I have added below lines  to all my vms vmx files but no use.


MemTrimRate = "0"

mainMem.useNamedFile = "FALSE"

sched.mem.pshare.enable = "FALSE"

prefvmx.useRecommendedLockedMemSize = "TRUE"


Can someone help me here?


Thanks,

Chaitanya.

1 Solution

Accepted Solutions
Chaitanyakumar_
Enthusiast
Enthusiast

Hi Shawn,

Thank you for your reply....

On initial boot if it is slow, that is fine. But this happens all of sudden even when I am working. When it freezes, i cant do anything. Just count numbers to kill some time.. :smileysilly: I have to wait till it is back to normal and I donno when that happens.

While i was searching on internet, someone posted in a website that disabling bits, superfetch and windows update services might reduce disk performance. I am 100% sure that they are stopped on my host windows machine. So, i disabled them. But i was really surprised to see the disk performance after I disabled those services. Now i have a lag for only very few seconds and that occurs only when i start the vms. After they are up and running there is no issue at all. I donno why a stopped service would cause such an impact. From now on, if i dont need a service, i will disable it, not stop it.

Finally, after disabling those 3 services, I have no issues.

Thanks,

Chaitanya.

View solution in original post

0 Kudos
8 Replies
huxiang
Enthusiast
Enthusiast

Hello Chaitanya,

Welcome to Workstation Community!

First of all, I'd like to say that when Windows system boots, 100% disk active time is normal. When I boot the Windows 10 on my physical machine, I can also see the 100% disk active time in task manager:

2016-03-22_17-16-01.png

Then I tried to boot a Windows 8.1 VM on this host, I got this:

2016-03-22_17-11-23.png

I checked the disk activity from Resource Monitor. The first interval of 100% disk active time was due to MSE(Microsoft Security Essentials - Microsoft Windows) scanning, the second interval of 100% disk active time was due to svchost.exe processes.

So if your physical disk performance is not very good (e.g. SSD), you'd better boot the Windows VM one by one. When the disk active time percentage goes down, you can boot a new one. High CPU and memory resource do not help for this situation.

I have an i7 host with 32GB memory at home. I also need much time to boot lots of Windows VMs... I plan to upgrade the physical disk to SSD...

Hope it helps.

Regards,

Shawn

Chaitanyakumar_
Enthusiast
Enthusiast

Hi Shawn,

Thank you for your reply....

On initial boot if it is slow, that is fine. But this happens all of sudden even when I am working. When it freezes, i cant do anything. Just count numbers to kill some time.. :smileysilly: I have to wait till it is back to normal and I donno when that happens.

While i was searching on internet, someone posted in a website that disabling bits, superfetch and windows update services might reduce disk performance. I am 100% sure that they are stopped on my host windows machine. So, i disabled them. But i was really surprised to see the disk performance after I disabled those services. Now i have a lag for only very few seconds and that occurs only when i start the vms. After they are up and running there is no issue at all. I donno why a stopped service would cause such an impact. From now on, if i dont need a service, i will disable it, not stop it.

Finally, after disabling those 3 services, I have no issues.

Thanks,

Chaitanya.

View solution in original post

0 Kudos
fracine16
Contributor
Contributor

VMWare 12 and Windows 10 = Slooooooooooooooooooow. Paid for an upgrade and not happy.

0 Kudos
galgitron
Contributor
Contributor

After a few weeks of every dead end imaginable, I finally found this page:

Windows 10 100% disk usage in Task Manager [SOLVED] - Driver Easy

and Method 7 was the solution.  You must perform this IN the VM, not in the host.  VMWare really needs to expose this solution on a broad scale because this is a serious performance issue and 'virtually' everyone will hit it.

Method 7: Fix your StorAHCI.sys driver

Note: A million thanks to our warm-hearted reader Javier for the following solution.

If you have tried all the above methods but still no avail, please see if this additional one helps.

The Windows 10 100% disk usage problem might also be caused by some Advanced Host Controller Interface PCI-Express (AHCI PCIe) models running with the inbox StorAHCI.sys driver due to a firmware bug.

Here’s how to determine if this is your problem and fix it:

1) Open Device Manager by pressing Windows logo key and X at the same time to choose Device Manager.

2) Expand the IDE ATA/ATAPI Controllers category, and double-click the AHCI controller.

3) Go to the Driver tab and click Driver Details. If you can see storahci.sys stored in a path of system32 folder, then you are running the inbox AHCI driver.

3) Close the Driver Details window and go to Details tab. From the drop-down menu, select Device Instance Path. Make note of the path, starting from VEN_.

4) Type regedit in the search box of Start panel, then hit Enter on your keyboard to run Registry Editor. Then go to:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Enum\PCI\ <AHCI Controller>\<Random Number>\Device Parameters\Interrupt Management\MessageSignaledInterruptProperties

The <AHCI Controller> here refers to the name you see from step 2).

The <Random Number> differs on different machines.

5) Double click the MSISupported key and change the value to 0.

6) Restart your computer after the change.

schollii
Contributor
Contributor

Not sure this worked for me, but also check that the VM has enough memory, per Disk usage 100% when run vmware on windows 10 - Microsoft Community

0 Kudos
technobrigade
Contributor
Contributor

This setting can increased the performance. My host is a 64 bit Linux pc with BFS and the timer is at 1500hz. My pc has 6GB physical ram and I created a 5GB ramdisk but it should also work with only 2GB of physical ram. tmpfs seems to dynamically allocate wanted ram. host.cpukHz needs to be exactly the host box cpu speed. mem.ShareScanThreshold needs to be exactly the guest box ram size. Start the guest box and install the vmware tools and let it install the virtual drivers for the hardisk, video card and so on. I've created a guest box with Windows XP SP3 OS and it works like a charm. It could be a little faster but my box is cpu limited. It's only a 2.2Ghz 64 bit dual core cpu and it's doesn't support hyperthreading. It's also good if the guest box has enough ram (2GB).

https://technobrigadeinfotech.com https://technobrigadeinfotech.com/mobile-app-development-company https://technobrigadeinfotech.com/php-web-development-company
0 Kudos
N8VZ
Contributor
Contributor

Thanks so much for posting this.  I had been so frustrated by the constant 100 percent disk usage that I was about to totally give up running the VM.  Once I followed your steps, my disk usage instantly went for pegged at 100 percent to ranging from 0 to 4 percent, and my VM became useable, almost like I was boot into Bootcamp.  Mine is a Bootcamp VM.  The change occurred in the Disk Usage before I even rebooted, as soon as I replaced the 1 with  a O in the key.  But, I rebooted just to be safe anyway.  You are really my hero of the day!! 

0 Kudos
jadonalford
Contributor
Contributor

Are you still facing the same issue?

Resource: https://192-168-1-1ip.info/

0 Kudos