Highlighted
Contributor
Contributor

vmware vm needs to obtain corp network IP

Hi there,

windows 10 pro + VMware workstation 16 pro.

My laptop is connected to our corp network through VPN. After I successfully create a linux vm (CentOS 8), I need it have corp network IP so other people in my team can have access (ssh, etc) to it.

How can I achieve it?

Now I use NAT, and vm IP address is something like 192.168.217.128, which is not what we need.

thanks a lot!

0 Kudos
5 Replies
Highlighted
Immortal
Immortal

Hi

the admins of your corp network may had cases like this request/plan in mind when they decided to enforce usage of a VPN.

In some companies even a first attempt to give an "unknown" Linux access into your protected network can fire back ...

I would suggest to play it by the book and contact the right person, Explain your need and request a solution.

Road with least resistance is probably an additional Wireless USB-adapter connected to the guest as an USB-device.

But that may look even more suspicious ...

Cant you let the Windows host do the job ?

Some more details would help ...

Do you need support with a recovery problem ? - call me via skype "sanbarrow"
0 Kudos
Highlighted
VMware Employee
VMware Employee

Your network team will know the specifics of how your corp network is setup and secured, they should be your first point of contact.

0 Kudos
Highlighted
Contributor
Contributor

thnx guys. But I think you get my question wrong.

I am asking if vmware is capable of doing what I was asking, it has nothing to do with my corp network settings at all.

All the things I plan to do with vmware are corp biz only, not personal hobby or experiment.

0 Kudos
Highlighted
VMware Employee
VMware Employee

The bottom line is that even if you used "bridged" rather than NAT your corporate VPN might mean it doesn't work anyway - multiple addresses on a single session.

0 Kudos
Highlighted
Contributor
Contributor

I tried both NAT and bridged, they dont work.

Probably vmware can't do it, that's totally fine. I just move on.

thanks!

0 Kudos