cinek2
Contributor
Contributor

vm workstation 9.0.2 poor performance

Getting really poor performance from workstation 9.0.2. It takes ages for Server 2008 r2 to load after making it a DC, when copying files from the host pc to the desktop of the VMs, explore freezes every time and needs to be restarted before the I can do anything. Also, loading MMCs is really slow, I'm following a couple of videos for e.g. exchange 2010 and I need to pause them all the time whenever something in exchange management tools needs to load/I expand something. Really considering getting rid of workstation and going for hyper-v

0 Kudos
6 Replies
weinstein5
Immortal
Immortal

Welcome to the COmmunity - What is the configuration of your laptop - memory and processors? WHat is the configuration of your VMs - memory and processors? and how many vms are you trying to run?

If you find this or any other answer useful please consider awarding points by marking the answer correct or helpful
0 Kudos
cinek2
Contributor
Contributor

PC specs:

CPU: intel i7 3770k
Memory:16GB

SSD: Crucial M4 128GB (this is where the VMs are installed, I have a seperate SSD for the main, host OS)

Doesn't matter if I run 1,2 or 3 VMs the performance is still bad. Same goes for the number of cores I assign

I usually assign 2 cpu cores & 2GB of ram & I increase that to 4 cores & 4-8GB of ram depending on the requirements. As I said that doesn't change anything

edit: forgot to mention I have vmware tools installed too, as that installs automatically on each VM

0 Kudos
a_p_
Leadership
Leadership

Please provide (attach) the .latest vmware.log file for one of the VM's which have poor performance, to see whether this file contains any hints. Often performance issues are caused by e.g. virtual CD-ROMs, which are in a "Connected" state.

André

0 Kudos
cinek2
Contributor
Contributor

attached

0 Kudos
a_p_
Leadership
Leadership

Please try to:

  • disconnect the virtual CD-ROM drive ("Connected" as well as "Connect at power on" disabled)
  • disconnect the virtual Floppy drive ("Connected" as well as "Connect at power on" disabled)
  • disable "Automatically connect new USB devices" from the USB Controller

do the above with the VM cleanly shut down (not suspended)

André

0 Kudos
cinek2
Contributor
Contributor

thanks, I think it might have improved the boot time a little bit, but the performance while the vm has booted up is still very poor imo

0 Kudos