davidbailey
Contributor
Contributor

symbol lookup error: /usr/lib64/libbonobo-2.so.0: undefined symbol: g_dgettext

Hello,

I'm testing VMware Workstation 6.5.3 with the latest openSUSE 11.2 snapshot, M7 on the 64-bit distribution.

The installer hangs while installing VMware Player (making the modules), but I was able to work around the problem with this method: http://communities.vmware.com/thread/228949

After getting VMware Workstation installed, launching it produces the following error:

/usr/lib/vmware/bin/vmware: symbol lookup error: /usr/lib64/libbonobo-2.so.0: undefined symbol: g_dgettext

After digging around, I found that installing glibmm2 solves this problem, but I cannot get either the mouse or keyboard to "grab" or connect to the guest system.

I found an option in this thread ( http://communities.vmware.com/thread/228499 ) to work around problems with GTK:

VMWARE_USE_SHIPPED_GTK=force vmware

However, when I use this option, I'm back to the "undefined symbol" error, and VMware Workstation no longer launches.

Any ideas?

System details and logs information below and attached.

openSUSE 11.2 Milestone 7 (x86_64)

VERSION = 11.2

LSB_VERSION="core-2.0-noarch:core-3.2-noarch:core-4.0-noarch:core-2.0-x86_64:core-3.2-x86_64:core-4.0-x86_64"

Kernel: Linux jet 2.6.31-rc9-7-desktop #1 SMP PREEMPT 2009-09-08 18:49:15 +0200 x86_64 x86_64 x86_64 GNU/Linux

gcc (SUSE Linux) 4.4.1

0 Kudos
1 Reply
davidbailey
Contributor
Contributor

A work-around for the problem has been found.

In short:

1. Install the Gnome pattern (software group) in YaST.

2. Append the line "export VMWARE_USE_SHIPPED_GTK=force" to the /etc/vmware/bootstrap file.

3. Use VMware Workstation or Player as usual. (You'll notice a difference in the GTK theme.)

    • Hopefully, VMware will get the software working with the latest GTK libraries in the next release!

http://forums.opensuse.org/pre-release-beta/422621-vmware-workstation-6-5-3-opensuse-11-2-m7-solved....

Have a lot of fun! :smileycool:

0 Kudos