feffer777
Contributor
Contributor

run a rescue disk in a vm?

Jump to solution

In a Fedora 11 vm on vmware workstation, I made an error editing a file. As a result, the boot process doesn't complete. I want to get the vm to boot to a rescue disk (the Fedora 11 install disk or any liveCD actually). I tried loading the install disk, and browsing to it in the CD settings of the vm, but it was ignored. Is there a way to do this?

feffer

0 Kudos
1 Solution

Accepted Solutions
Scissor
Virtuoso
Virtuoso

>Yes, that's what I thought. I tried those steps, but while powering on the vm could not get to the BIOS. Tried this several times with all possible combinations of F2, F12 and esc. The boot went right past it, and hung before finishing.

The BIOS splash screen goes by so fast that it's almost impossible to get into the BIOS setup without running the VM -> Power -> Power on to BIOS option. (See screenshot)

What version of VMware Workstation are you running?

View solution in original post

0 Kudos
9 Replies
Scissor
Virtuoso
Virtuoso

In a Fedora 11 vm on vmware workstation, I made an error editing a file. As a result, the boot process doesn't complete. I want to get the vm to boot to a rescue disk (the Fedora 11 install disk or any liveCD actually). I tried loading the install disk, and browsing to it in the CD settings of the vm, but it was ignored. Is there a way to do this?

Make sure the virtual CD-ROM is configured to be "connected" at power on. Then select VM -> Power On -> Power on to BIOS. Then once you are in the Guest BIOS you can change the boot order so that it tries to boot from the CD-ROM before the Hard drive.

0 Kudos
feffer777
Contributor
Contributor

EDIT: spoke too soon. I had the CD set to be enabled at power on, but instead of point to the cdrom device, I was trying to navigate to it's path. In the BIOS now, hope I can get it going. Thx

Yes, that's what I thought. I tried those steps, but while powering on the vm could not get to the BIOS. Tried this several times with all possible combinations of F2, F12 and esc. The boot went right past it, and hung before finishing.

0 Kudos
Scissor
Virtuoso
Virtuoso

>Yes, that's what I thought. I tried those steps, but while powering on the vm could not get to the BIOS. Tried this several times with all possible combinations of F2, F12 and esc. The boot went right past it, and hung before finishing.

The BIOS splash screen goes by so fast that it's almost impossible to get into the BIOS setup without running the VM -> Power -> Power on to BIOS option. (See screenshot)

What version of VMware Workstation are you running?

View solution in original post

0 Kudos
feffer777
Contributor
Contributor

OK, thx I didn't know about the power on to BIOS. I guess I just finally got lucky.

0 Kudos
Scissor
Virtuoso
Virtuoso

Cool. So were you able to sucessfully boot your rescue disk?

0 Kudos
feffer777
Contributor
Contributor

Yes, now to undo the error. It all started because the scrollwheel mouse action didn't work. I tried altering xorg.conf. Made a copy of course, but I think the newer xorg stuff (handled by HAL now, I think) didn't like my edit.

0 Kudos
Scissor
Virtuoso
Virtuoso

Glad to hear it! Remember to take a snapshot before making changes in the future -- much easier to "revert" a snapshot then dealing with rescue CD's.

Have a great weekend! dont' forget to mark this question as answered if it has been (answered).

0 Kudos
RDPetruska
Leadership
Leadership

Glad to hear it! Remember to take a snapshot before making changes in the future -- much easier to "revert" a snapshot then dealing with rescue CD's.

Or, just zip up the virtual machine folder yourself outside of VMware to create a fully portable/restorable backup of your working VM. Even easier than waiting to create the snapshot, and then having to deal with restoring one or cleaning up one at a later date! Smiley Happy

0 Kudos
feffer777
Contributor
Contributor

lol, that's a good idea. Especially considering what I had to do to restore the vm! It was Fedora 11 which uses ext4 natively, but also creates a separate /boot partition that's ext3. The problem was a bad edit in xorg.conf. Not only would X not start, but the boot wouldn't finish. After booting to the BIOS (thx for that -- I was unfamiliar with that feature), I could get my Knoppix rescue disk to boot, and it could mount the /boot partition but not the root! Vmware either doesn't handle ext4 or Fedora does something strange on the install -- the root partition was of the type "lvm2" (logical volume, I guess). It would not mount. Finally, I edited /boot/grub/menu.lst to load the kernel "single" user. Then Fedora would boot, and I could fix my xorg.conf mistake. Funny, I back up everything else! Thx again for your help.

feffer

To whom much has been given, much will be expected.

0 Kudos